Expand my Community achievements bar.

July 31st AEM Gems Webinar: Elevate your AEM development to master the integration of private GitHub repositories within AEM Cloud Manager.
SOLVED

installation issue with org.apache.servicemix.bundles.esapi bundle

Avatar

Level 2

I am getting below errors after installing org.apache.servicemix.bundles.esapi , could anyone please help me with this to resolve.

 

bsh -- Cannot be resolved but is not required
javax.crypto from org.apache.felix.framework (0)
javax.crypto.spec from org.apache.felix.framework (0)
javax.servlet from org.apache.felix.http.servlet-api (37)
javax.servlet.http from org.apache.felix.http.servlet-api (37)
javax.servlet.jsp from org.apache.sling.scripting.jsp-api (716)
javax.servlet.jsp.tagext from org.apache.sling.scripting.jsp-api (716)
javax.xml.parsers from org.apache.felix.framework (0)
javax.xml.transform from org.apache.felix.framework (0)
javax.xml.transform.stream from org.apache.felix.framework (0)
javax.xml.validation from org.apache.felix.framework (0)
nu.xom -- Cannot be resolved but is not required
org.apache.commons.beanutils,version=[1.9,2) -- Cannot be resolved
org.apache.commons.collections.iterators,version=[3.2,4) from org.apache.commons.collections (53)
org.apache.commons.configuration,version=[1.10,2) -- Cannot be resolved
org.apache.commons.fileupload,version=[1.4,2) from org.apache.commons.commons-fileupload (832)
org.apache.commons.fileupload.disk,version=[1.4,2) from org.apache.commons.commons-fileupload (832)
org.apache.commons.fileupload.servlet,version=[1.4,2) from org.apache.commons.commons-fileupload (832)
org.apache.commons.fileupload.util,version=[1.4,2) from org.apache.commons.commons-fileupload (832)
org.apache.commons.lang.text,version=[2.6,3) from com.day.commons.osgi.wrapper.commons-lang2 (52)
org.owasp.validator. html,version=[1.4,2) -- Cannot be resolved
1 Accepted Solution

Avatar

Correct answer by
Level 6

If you have followed the above mentioned article then there is a Export-Package section where explicitly packages are exported to achieve that part. Concentrate on that section and depending on your build plugin make the changes to export the same . That should help you in resolving the above errors.

View solution in original post

6 Replies

Avatar

Level 6

HI @nalithamsa ,

If you are planning to use ESAPI logging framework then check using org.owasp.esapi bundle. Hope below article will be helpful .

https://www.kryptonsquare.com/services/Consulting/Adobe-experience-manager-implementation-expert/aem...

 

You have to check the compatibility of other esapi packages with AEM version in case you like to use them in your project. Above issues appear due to incompatibility with different versions.

Thanks,

Somen

Avatar

Level 2

Hi @somen-sarkar , 

Thank you for the quick response. I tried adding the same bundle you mentioned in my core bundle pom. xml file,

<dependency>
<groupId>org.owasp.esapi</groupId>
<artifactId>esapi</artifactId>
<version>2.5.3.1</version>
</dependency>

but I am getting error  after uploading my core bundle and that is not going to active state. 

org.owasp.esapi,version=[2.2,3) -- Cannot be resolved

 

then I tried to upload the jar of esapi directly on console, then I am getting below error. please help me with possible solution. thank you!!

HTTP ERROR 500 Server Error

URI:STATUS:MESSAGE:SERVLET:CAUSED BY:

/system/console/bundles
500
Server Error
org.apache.felix.http.base.internal.dispatch.DispatcherServlet-2671d930
java.io.IOException: Bundle-SymbolicName header missing, cannot install bundle

Caused by:

java.io.IOException: Bundle-SymbolicName header missing, cannot install bundle

 

Avatar

Correct answer by
Level 6

If you have followed the above mentioned article then there is a Export-Package section where explicitly packages are exported to achieve that part. Concentrate on that section and depending on your build plugin make the changes to export the same . That should help you in resolving the above errors.

Avatar

Level 2

Thank you @somen-sarkar , errors has been resolved. but the bundle is in installed state only and not turning to active state even if I start it. am I missing something else? please let me know.

Avatar

Community Advisor

@nalithamsa 

 

PLease cross-check if "org.owasp.esapi" also has some dependencies which are not getting resolved. They would appear in red, the same way as your original post.

 

Also, please check error.log when you are clicking on start button for the bundle


Aanchal Sikka

Avatar

Level 2

Hi @aanchal-sikka 

 

I have checked the error logs, found that I am using same packages in two different bundles inside export-packages tag of pom file . So, I have removed the duplicates and all the errors got resolved. Moreover, I kept this "org.owasp.esapi"  dependency inside export packages as mentioned by @somen-sarkar  . Thank you both.