Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

In Authoring environment RTE in Touch ui show empty when anchor link and latter source edit is clicked (AEM6.3 with SP2)

srinivas_chann1
Level 7
Level 7

Hello,

 

1>On using RTE to just have anchor link  by giving an label

2> latter on clicking source edit  shows an  empty.

 

We want to add in rte anchor tag like

 

<a id="test"> </a>  ,

Note:- Here the title is empty for the anchor link and not getting allowed by RTE

 

 

The use case we would want just a anchor link with some custom code added to it without any title.

Issue is  on submitting the dialog and on re-opening does not have the anchor link. Touch UI anchor icon added with a label:-

RTE with only anchot link.PNG

 

 

Source edit clicked and turned off:-

source edit remvoes code.PNG
Please let me know as how this could be solved

 

 

Thanks

 

 

Thanks

1 Accepted Solution
Nirmal_Jose
Correct answer by
Community Advisor
Community Advisor

Hi,

Once you re-open the dialog and see that the anchor tag is no more appearing, is the <a id="someid"></a> visible on source editor view or that is trimmed off. If its trimmed off, mostly link checker might be removing a bad link. Please follow [1] to disable link checker as a whole or for a single use case.

 

[1] - https://helpx.adobe.com/in/experience-manager/kb/how-to-configure-linkchecker-tomark-alllinks-asvali...

View solution in original post

0 Replies
Nirmal_Jose
Correct answer by
Community Advisor
Community Advisor

Hi,

Once you re-open the dialog and see that the anchor tag is no more appearing, is the <a id="someid"></a> visible on source editor view or that is trimmed off. If its trimmed off, mostly link checker might be removing a bad link. Please follow [1] to disable link checker as a whole or for a single use case.

 

[1] - https://helpx.adobe.com/in/experience-manager/kb/how-to-configure-linkchecker-tomark-alllinks-asvali...

View solution in original post

srinivas_chann1
Level 7
Level 7

Hi,

 

Thanks for the input.  

 

On the Link https://helpx.adobe.com/in/experience-manager/kb/how-to-configure-linkchecker-tomark-alllinks-asvali...

I had 2 queries.Could you please provide inputs as how this work for RTE:-

 

1>In which file should i add the below ,so that RTE will bypass the link validation

Optionally use x-cq-linkchecker="skip" in the <a>. Link Checker will not even check for validity

 

2>The Link Checker should not be enabled on publish instances

How to achieve this that it works in author but is not enabled in publish

 

Thanks

srinivas_chann1
Level 7
Level 7

Hi,

Thanks for the input.

On the Link https://helpx.adobe.com/in/experience-manager/kb/how-to-configure-linkchecker-tomark-alllinks-asvali...

 

 

I had 2 queries.Could you please provide inputs as how this work for RTE:- 1>

In which file should i add the below ,so that RTE will bypass the link validation Optionally use x-cq-linkchecker="skip" in the . Link Checker will not even check for validity 2>The Link Checker should not be enabled on publish ...

srinivas_chann1
Level 7
Level 7

Hi,

 

Thanks for the input.  

 

On the Link https://helpx.adobe.com/in/experience-manager/kb/how-to-configure-linkchecker-tomark-alllinks-asvali...

I had 2 queries.Could you please provide inputs as how this work for RTE:-

 

1>In which file should i add the below ,so that RTE will bypass the link validation

Optionally use x-cq-linkchecker="skip" in the <a>. Link Checker will not even check for validity

 

2>The Link Checker should not be enabled on publish instances

How to achieve this that it works in author but is not enabled in publish

 

Thanks

Bhavani_B
Level 2
Level 2
Hi srinivas_chann1, I am trying to add the anchor tag in RTE but i didnt find the Correct steps to implement, can you please help to solve my issue. Thanks in advance