Highlighted

iFrame in Rich Text Editor

nevs81819115

30-09-2017

Hi Community,

I'm trying to add an iframe via rich text editor (RTE). It works whilst in edit mode but after I click save it no longer appears because the src attribute has been stripped from the iframe element. I guess this means the RTE does not support iframe by default. Is this correct? If so can the RTE be configured to support iframe?

Many thanks in advance.

Replies

Highlighted

smacdonald2008

02-10-2017

I do not think this is supported - i am double checking.

I am not clear why you would even want an iframe for a RTE.

Highlighted

iainc65537558

18-06-2018

Hi,

Just to clarify, are you saying that using the Core text component it is possible to include an iframe where the src attribute is not removed?

Highlighted

smacdonald2008

18-06-2018

As i asked in the thread last year - why do you want to override the RTE by using an IFRAME. The RTE works fine as is.

Highlighted

Rajashankar

11-06-2020

Hi Mac,

I am slo getting same issue with RTE component 

I added below text in RTE:

<p><iframe width="560" height="315" src="https://www.youtube.com/embed/pQf4qIju0_E"></iframe></p>
<p><iframe width="560" height="315" src="https://player.vimeo.com/video/33698814"></iframe></p>

 

Now when i exit the edit mode and preview in page its showing only youtuve whereas vimeo or anyother player its not showing up.Its cleaning it up automatically as shown below.

<p><iframe width="560" height="315" src="https://www.youtube.com/embed/pQf4qIju0_E">&amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;...>
<p><iframe width="560" height="315">&amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;nbsp;</iframe></p>