Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Help required for AEM to Adobe Analytics Integration

manishs40044499
Level 4
Level 4

Hi All,

I am totally new to AEM but worked on Adobe Analytics, DTM and Target.

Currently I am trying for AEM to adobe analytics integration. For that I have implemented the cloud services (DTM) on particular page(AEM) and all are working fine and adobe analytics also capturing data. But all this configuration done on author instance of AEM (correct me if I am wrong). Now if we are publishing the page so that the page can be accessed outside of AEM directly, We are not receiving data to analytics. As per my knowlegde author instance is working on 4502 port whereas publish instance is working on 4503 port and hence the issue.

​Now how to fix this issue. How can I configure cloud services for publish instance.

​Thanks

Manish

1 Accepted Solution
Feike_Visser1
Correct answer by
Employee
Employee

via /miscadmin you can activate the cloudservices.

You need to compare if needed author/publish what is missing

View solution in original post

12 Replies
kautuk_sahni
Community Manager
Community Manager

1. Have you set the production settings tab values ?

1240215_pastedImage_1.png

2. Have you set the report suit for production in DTM while adding Analytics tool?

Feike_Visser1
Employee
Employee

Also verify that you have published the cloudservices, and the page(s) where you have connected the cloudservice.

manishs40044499
Level 4
Level 4

Hi Feike,

Please guide me how can I publish the cloudservices seperately as I published the whole page already. I am not getting any such option.

Thanks

Manish

manishs40044499
Level 4
Level 4

Hi Kautuk,

Thanks for your reply!

Yes Production settings are in place but still not getting the data. Please help!

Thanks

Manish

Feike_Visser1
Correct answer by
Employee
Employee

via /miscadmin you can activate the cloudservices.

You need to compare if needed author/publish what is missing

View solution in original post

manishs40044499
Level 4
Level 4

Hi Feike,

Thanks for the help!

As you suggested I have published(activate) the cloud services through miscadmin and after that I am able to see the DTM head script(production) on the page but same is not getting executed. Please find the network response below and help me to troubleshoot this.

Dynamic Tag Management
Adobe Analytics

1240755_pastedImage_0.png

Feike_Visser1
Employee
Employee

Looks like the DTM-lib can't be found, did you publish your DTM-changes?

Feike_Visser1
Employee
Employee

Can you check in a separate browser tab if the DTM-lib loads? Also check for http vs https

manishs40044499
Level 4
Level 4

Hi Feike,

Thanks for your help!
Now everything is working perfectly fine.

Thanks

Manish

kautuk_sahni
Community Manager
Community Manager

manishs40044499

Glad that it is working for you. Would you please let us know how did it work? This would help all the future members facing similar problem. Thanking you in advance.

~kauutk

manishs40044499
Level 4
Level 4

Hi Kautuk,

I simply followed the comments, thanks to Feike Visser First I activated the cloud services from miscadmin at AEM end and then published the web property at DTM end.

Thanks

Manish