Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

fixing the segment store

akank_23
Level 2
Level 2

Hi All,

 

Our site is showing 503 error and checking the logs it shows segment store is corrupted.

On fixing the segment store and running the checkpoints it is showing this error 

 

[root@**** publish]# java -Xmx6000m -jar oak-run-1.2.2.jar checkpoints /data/apps/aem/publish/crx-quickstart/repository/segmentstore rm-unreferenced
Apache Jackrabbit Oak 1.2.2
Checkpoints /data/apps/aem/publish/crx-quickstart/repository/segmentstore
11:15:14.144 [main] ERROR o.a.j.o.p.segment.SegmentTracker - Segment not found: 00000000-0000-0000-0000-000000000000. Creation date delta is 2 ms.
Segment 00000000-0000-0000-0000-000000000000 not found
 
any pointers may help 

 

4 Replies
Vijayalakshmi_S
Community Advisor
Community Advisor

Hi @akank_23,

Can you confirm if oak-run version used is same as that of your instance. Please share your AEM and Oak version(as available in the instance)

 

If you are following the steps mentioned in the this article - https://experienceleague.adobe.com/docs/experience-cloud-kcs/kbarticles/KA-16542.html

and if you have backup of your instance's segmentstore,

  • I suggest to restore the same and follow steps 1 - 5 alone. 
  • If you have repo.lock file, delete that as well after step 5 -> try to restart the instance at this stage and see if it works. 

If you still face issues, please share the sequential steps followed and stack error trace. 

Vijayalakshmi_S
Community Advisor
Community Advisor
Ok. Did you get a chance to try the procedure again as said previously (By restoring the backup -> trying again till step 5)
akank_23
Level 2
Level 2
No not yet , it is production env not sure how to restore the backup