Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Facing High Load Issue on PROD Publishers, while installing a AEM React package.

Avatar

Level 1

Hi Team,

We are facing High Load issue in PROD Publisher

 

At the time of deployment on publisher, when we are trying to install the AEM React Package, the load on the publishers is getting high and the installation of the packages is getting stopped.

We have stopped the dispatchers to reduce the load on the publishers, then after 3 to 4 minutes the load on the publishers is getting reduced and the packages are getting installed.

 

Can you please let us know why this is happening with particular package and how we can reduce the high load issue without stopping the dispatchers.

 

Thanks in advance

 

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

@sush6 As this is performance related issue with the Production instances,

1. What's the CPU/Memory utilization during deployment in Publishers ?
2. Are we getting the same issue in lower environment servers ?
3. Are we seeing the same issue in Production Author while installing the package ? If yes - what's the configuration change between Author & Publisher ?
4. What's the ERROR you are getting while installing the package in Publisher ?
5. Can you tail the ERROR Log while installing the package in Publisher ?
6. Try to take the thread-dumps while installing the package in Publisher - to analyze the issue further.

 

Regards,

Raja

View solution in original post

2 Replies

Avatar

Correct answer by
Community Advisor

@sush6 As this is performance related issue with the Production instances,

1. What's the CPU/Memory utilization during deployment in Publishers ?
2. Are we getting the same issue in lower environment servers ?
3. Are we seeing the same issue in Production Author while installing the package ? If yes - what's the configuration change between Author & Publisher ?
4. What's the ERROR you are getting while installing the package in Publisher ?
5. Can you tail the ERROR Log while installing the package in Publisher ?
6. Try to take the thread-dumps while installing the package in Publisher - to analyze the issue further.

 

Regards,

Raja

Avatar

Level 3

Hi @sush6

 

1. Do request log analysis to know which request is taking huge time around the package installation.

2. Check for errors in error.log to see if this issue is happening at the time of bundle installation. Business logic in OSGi services' activate and deactivate methods could cause the issue sometimes.

3. If you could not figure out from error.log then do thread-dump analysis.