Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Experience Fragment Blank page

Avatar

Avatar
Validate 25
Level 4
varuns46785756
Level 4

Likes

22 likes

Total Posts

146 posts

Correct Reply

2 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Ignite 5
Ignite 3
View profile

Avatar
Validate 25
Level 4
varuns46785756
Level 4

Likes

22 likes

Total Posts

146 posts

Correct Reply

2 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Ignite 5
Ignite 3
View profile
varuns46785756
Level 4

24-06-2019

Hi All,

I am creating Experience fragment first time in AEM6.4 as per the instruction in this link (Experience Fragments ) but when I am creating Experience fragment I am not getting fields to enter the values, I am getting blank page like below screen shot:

1778795_pastedImage_3.png

it should be like second screen shot, is there anything extra do I need to add here, Please suggest:

It's working fine in AEM6.3, only issue in AEM6.4.

1778796_pastedImage_4.png

Regards,

Replies

Avatar

Avatar
Give Back 5
Level 4
Bharath_valse
Level 4

Likes

34 likes

Total Posts

65 posts

Correct Reply

11 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 25
Give Back 10
Give Back
View profile

Avatar
Give Back 5
Level 4
Bharath_valse
Level 4

Likes

34 likes

Total Posts

65 posts

Correct Reply

11 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 25
Give Back 10
Give Back
View profile
Bharath_valse
Level 4

24-06-2019

Couple of things you could try:

- Make sure to check  XF related overlays under /apps. Disable the overlays(by renaming the overlay folder) and check again. eventually fix the overlay by comparing the /libs file

- Try clearing browser cache and retry again

- Any browser console errors or backend error in the logs?

Avatar

Avatar
Validate 25
Level 4
varuns46785756
Level 4

Likes

22 likes

Total Posts

146 posts

Correct Reply

2 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Ignite 5
Ignite 3
View profile

Avatar
Validate 25
Level 4
varuns46785756
Level 4

Likes

22 likes

Total Posts

146 posts

Correct Reply

2 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Ignite 5
Ignite 3
View profile
varuns46785756
Level 4

24-06-2019

Hi Bharath,

I don't have any overlays under /app and even no console error.Same thing is working in AEM6.3 but not in AEM6.4.

Do I need to install any other package.I have installed SP6.4.2 and acs-commons-3.16.1

Avatar

Avatar
Give Back 5
Level 4
Bharath_valse
Level 4

Likes

34 likes

Total Posts

65 posts

Correct Reply

11 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 25
Give Back 10
Give Back
View profile

Avatar
Give Back 5
Level 4
Bharath_valse
Level 4

Likes

34 likes

Total Posts

65 posts

Correct Reply

11 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 25
Give Back 10
Give Back
View profile
Bharath_valse
Level 4

24-06-2019

The properties within the wizard is derived from below path

/libs/cq/experience-fragments/components/experiencefragment/cq:dialog/content/items/tabs/items/basic/items/column_1/items

make sure these properties exists in the above path. If they exist, make sure to check  XF templates /libs/cq/experience-fragments/components/experiencefragment/template have no overlays

Also you could try Rebuilding Clientlibs

Goto http://localhost:4502/libs/granite/ui/content/dumplibs.rebuild.html

Click on "Invalidate Caches"

Click on "Rebuild Libraries", this might take ~10mins to complete. please wait till the browser loads completely

If its your local instance, please rebuild you instance. XF should work with 6.4 without any service packs.

Avatar

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,282 likes

Total Posts

3,156 posts

Correct Reply

891 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,282 likes

Total Posts

3,156 posts

Correct Reply

891 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile
Arun_Patidar
MVP

25-06-2019

Hi,

Are you using OOTB templates or did you created your own templates for XF.

Make sure you the template's sling:resourceType point to the correct page component.

The issues seems with missing resource or other super resources which part of XF template

Avatar

Avatar
Contributor
Employee
hamidk92094312
Employee

Likes

102 likes

Total Posts

240 posts

Correct Reply

38 solutions
Top badges earned
Contributor
Shape 1
Ignite 1
Give Back 50
Give Back 5
View profile

Avatar
Contributor
Employee
hamidk92094312
Employee

Likes

102 likes

Total Posts

240 posts

Correct Reply

38 solutions
Top badges earned
Contributor
Shape 1
Ignite 1
Give Back 50
Give Back 5
View profile
hamidk92094312
Employee

25-06-2019

You may wanna ensure you have the proper user permissions to perform this task.
http://host:port/useradmin

Avatar

Avatar
Validate 25
Level 4
varuns46785756
Level 4

Likes

22 likes

Total Posts

146 posts

Correct Reply

2 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Ignite 5
Ignite 3
View profile

Avatar
Validate 25
Level 4
varuns46785756
Level 4

Likes

22 likes

Total Posts

146 posts

Correct Reply

2 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Ignite 5
Ignite 3
View profile
varuns46785756
Level 4

25-06-2019

Hi All,

Thanks for all the suggestions.

@Bharath: I have create new local AEM6.4 instance and its working fine now, without doing or installing anything.I am not sure what is the wrong with my previous AEM instance. Now I have created XF by using default weretail template and using the same on my page.

XF on auhtor: http://localhost:4502/content/experience-fragments/kop/tos/master.html

XF on publish: http://localhost:4503/content/experience-fragments/kop/tos/master.html

Page name;

author: http://localhost:4502/content/we-retail/language-masters/en/tos.html

publish http://localhost:4503/content/we-retail/language-masters/en/tos.html

Now I need to share the content( image and text) of this page with third party website and there website is running on different technology not on AEM. How can I share the content with them.

Regards,

Avatar

Avatar
Give Back 5
Level 4
Bharath_valse
Level 4

Likes

34 likes

Total Posts

65 posts

Correct Reply

11 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 25
Give Back 10
Give Back
View profile

Avatar
Give Back 5
Level 4
Bharath_valse
Level 4

Likes

34 likes

Total Posts

65 posts

Correct Reply

11 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 25
Give Back 10
Give Back
View profile
Bharath_valse
Level 4

25-06-2019

Please go through document [1] which might be helpful for exposing XF

[1]

Adobe Experience Manager Help | Understanding Content Fragments and Experience Fragments in AEM

Avatar

Avatar
Validate 25
Level 4
varuns46785756
Level 4

Likes

22 likes

Total Posts

146 posts

Correct Reply

2 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Ignite 5
Ignite 3
View profile

Avatar
Validate 25
Level 4
varuns46785756
Level 4

Likes

22 likes

Total Posts

146 posts

Correct Reply

2 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Ignite 5
Ignite 3
View profile
varuns46785756
Level 4

25-06-2019

I have tried and converting the XF in json format but what about the use of  "plain"  in master.plain.html".

Can I use this to share the content with different web applications.When I am using "plain" parameter in publish url: http://localhost:4503/content/experience-fragments/kop/tos/master.plain.html

I am getting below error:

1

Cannot serve request to /content/experience-fragments/kop/tos/master.plain.html on this server


ApacheSling/2.6 (jetty/9.3.22.v20171030, Java HotSpot(TM) 64-Bit Server VM 1.8.0_211, Windows 10 10.0 amd64)
Regards,

Avatar

Avatar
Validate 25
Level 4
varuns46785756
Level 4

Likes

22 likes

Total Posts

146 posts

Correct Reply

2 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Ignite 5
Ignite 3
View profile

Avatar
Validate 25
Level 4
varuns46785756
Level 4

Likes

22 likes

Total Posts

146 posts

Correct Reply

2 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Ignite 5
Ignite 3
View profile
varuns46785756
Level 4

26-06-2019

Hi All,

Please suggest on the below error while using  " plain " in URL in publish getting the error only in publish instance:

1

Cannot serve request to /content/experience-fragments/kop/tos/master.plain.html on this server


ApacheSling/2.6 (jetty/9.3.22.v20171030, Java HotSpot(TM) 64-Bit Server VM 1.8.0_211, Windows 10 10.0 amd64)