Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Error wcmmode disabled

jlfera
Level 2
Level 2

Hello,

I have a page in my AEM Author, and I get an error when I click in the menu "View as Published".

Instance version: Adobe Experience Manager: 6.5.3.0

 

The URL:

https://authorXXX.adobedemo.com/content/example.html?wcmmode=disabled

 

The error:

org.apache.sling.api.SlingException: Cannot get DefaultSlingScript: org.apache.sling.api.SlingException: Cannot get DefaultSlingScript: org.apache.sling.api.SlingException: Cannot get DefaultSlingScript: Operands are not of the same type: comparison is supported for Number types only.

 

Cannot serve request to /content/example.html on this server

 

ApacheSling/2.6 (jetty/9.4.20.v20190813, OpenJDK 64-Bit Server VM 1.8.0_232, Linux 3.10.0-862.14.4.el7.x86_64 amd64)

 

How can I fix this problem?

Thanks.

 

 

1 Accepted Solution
BrianKasingli
Correct answer by
Community Advisor
Community Advisor

@jlfera,

Have you installed all your packages such as ui.apps, core, package-dependencies into your AEM environment? Does your bundle depend on any content structure to perform as expected? Your error code does not have sufficient detail, can you please provide us with more information from the logs? Can you please analyse your AEM instance using these basic steps to debug AEM, https://sourcedcode.com/blog/aem/development/basic-steps-to-debug-an-error-in-aem, and let us know what you find?

View solution in original post

1 Reply
BrianKasingli
Correct answer by
Community Advisor
Community Advisor

@jlfera,

Have you installed all your packages such as ui.apps, core, package-dependencies into your AEM environment? Does your bundle depend on any content structure to perform as expected? Your error code does not have sufficient detail, can you please provide us with more information from the logs? Can you please analyse your AEM instance using these basic steps to debug AEM, https://sourcedcode.com/blog/aem/development/basic-steps-to-debug-an-error-in-aem, and let us know what you find?

View solution in original post