Expand my Community achievements bar.

Applications for the 2024-2025 Adobe Experience Manager Champion Program are open!

Enabling ESI:Include on Akamai (SDI)

Avatar

Level 4

Hello - We are in the processing of enabling esi:include (Edge Side Include) on Akamai. We have added a Behavior for this rule in Akamai but still the tags are not evaluated in CDN. We are trying to implement the SDI in our project and decided to go with ESI to exclude the component from the caching. Can someone tell me what other changes are required in Akamai for this scenario. 

6 Replies

Avatar

Community Advisor

Hi,

 

You can check below document 

 

https://www.akamai.com/us/en/multimedia/documents/technical-publication/akamai-esi-developers-guide-...

 

The changes can be done by Akamai team and akamai team members can provide more insights on the change needed at their end

 

 

Avatar

Level 4
@Ravi_Pampana - Thanks for your reply. I have already gone through this document but it has no details about what needs to be changed to support esi:include tag.

Avatar

Community Advisor

 

We had implemented ESI with attached config file.

You need to simply put the config file in the config.publish run mode.

 

Hope this will help.

 

Umesh Thakur

Avatar

Level 4

@Umesh_Thakur - I don't see any attachment. Please upload if any.

Also for ESI include, I have already made the required changes in the run-modes. I am looking for Akamai changes to enable ESI:Include. I have enabled it but for some reason, the tags are not evaluated.

 

Avatar

Level 2

@aemninja Looks like you were also implement the ESI on AEM and having the similar issues. 

 

Are you able to resolve issues and implement successfully? If yes, It would be really great if you can share the details.

Avatar

Level 2

@Umesh_Thakur  Looks like you were able to implement and use ESI successfully on AEM Pages created using the Static/Editable templates.

 

We have the similar use case to use ESI and load & render the content directly from CDN(Akamai),  (<esi:include src="https://www.xyz.com/esi/nas/header/v1/header.html" onerror="continue"/> but somehow <esi:include> tag is not resolving or disappearing on the page and the content was not pulled & rendered on the page.

 

It would be really great if you can share more details about your implementation with the examples. Can you also share the OSGI configuration details you have added/included in the run modes.