Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Enabling Dynamic Media AEM 6.5

jlfera
Level 2
Level 2

Hello.
I am working with cq-quickstart-6.5.0.jar in local, and the VM is updated with last version (6.5.6.0).
Following the indication of the link:
https://docs.adobe.com/content/help/en/experience-manager-65/assets/dynamic/config-dms7.html

I’m starting the VM with the commands:
java -Xms4096m -Xmx4096m -Doak.queryLimitInMemory=500000 -Doak.queryLimitReads=500000 -jar cq-quickstart-6.5.0.jar -gui -r author,dynamicmedia_scene7 -p 4502

The AEM is starting OK, but I can’t see the Dynamic Media active. After initiate the VM (with the dynamicmedia_scene7 commands), I have to do something more?

Thanks.

1 Accepted Solution
Jineet_Vora
Correct answer by
Level 4
Level 4

Hello @jlfera,

 

In your command add the debug flag to verify the runmode in CMD:
java -Xdebug -Xms4096m -Xmx4096m -Doak.queryLimitInMemory=500000 -Doak.queryLimitReads=500000 -jar cq-quickstart-6.5.0.jar -gui -r author,dynamicmedia_scene7 -p 4502

After AEM instance is up double check the runmode from AEM: http://localhost:4502/system/console/status-slingsettings

Also check the configuration of Dynamic Media Configuration in the Cloud Services section: http://localhost:4502/libs/dam/content/configurations/dmscene7.html/conf. If you have the configuration already in-place you will see the /content/dam/_CSS and /content/dam/_DMSAMPLE folders sync'd to your localhost.  

If above everything is in place then upload a sample asset and check whether the Scene7 metadata is updated for that node:
<Asset_Path>/jcr:content/metadata and you will find below properties:

Annotation 2020-09-17 034528.png

 

Hope this helps!

Jineet

View solution in original post

3 Replies
Jineet_Vora
Correct answer by
Level 4
Level 4

Hello @jlfera,

 

In your command add the debug flag to verify the runmode in CMD:
java -Xdebug -Xms4096m -Xmx4096m -Doak.queryLimitInMemory=500000 -Doak.queryLimitReads=500000 -jar cq-quickstart-6.5.0.jar -gui -r author,dynamicmedia_scene7 -p 4502

After AEM instance is up double check the runmode from AEM: http://localhost:4502/system/console/status-slingsettings

Also check the configuration of Dynamic Media Configuration in the Cloud Services section: http://localhost:4502/libs/dam/content/configurations/dmscene7.html/conf. If you have the configuration already in-place you will see the /content/dam/_CSS and /content/dam/_DMSAMPLE folders sync'd to your localhost.  

If above everything is in place then upload a sample asset and check whether the Scene7 metadata is updated for that node:
<Asset_Path>/jcr:content/metadata and you will find below properties:

Annotation 2020-09-17 034528.png

 

Hope this helps!

Jineet

View solution in original post

jlfera
Level 2
Level 2
Thank for your time Jineet. I can see that my problem is the Dynamic Media Configuration in the Cloud Services.