Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Double click on Classic dialog icon in crxde

Avatar

Level 2

If we double click on the classic dialog icon in the component node structure in crxde, a page opens up in a new tab where we can see the dialog layout.

url : localhost:4502:<<path-to-component>>/dialog.html

Issue : For some dialogs , a blank page opens up even though the dialog is properly constructed and is already used in components. Some AEM folks have suggested that this happens because of the custom listeners in the component and AEM is unable to evaluate custom listeners output while rendering the dialog. However , this issue is observed in some /libs components as well.

For ex : /libs/foundation/components/video

/libs/foundation/components/title

Is it an expected scenario/known product behaviour ?

There is a common console error for all these components. Please find attached the screenshot WhatsApp Image 2017-11-10 at 13.54.59.jpeg

1 Accepted Solution

Avatar

Correct answer by
Level 6

I just tested on AEM 6.2 this use case. i cannot replicate this issue

/libs/foundation/components/title/dialog

http://localhost:4533/libs/foundation/components/title/dialog.html

1345536_pastedImage_2.png

/libs/foundation/components/video/dialog

http://localhost:4533/libs/foundation/components/video/dialog.html

1345537_pastedImage_5.png

May be this is your environment and your custom listeners specific.

View solution in original post

2 Replies

Avatar

Correct answer by
Level 6

I just tested on AEM 6.2 this use case. i cannot replicate this issue

/libs/foundation/components/title/dialog

http://localhost:4533/libs/foundation/components/title/dialog.html

1345536_pastedImage_2.png

/libs/foundation/components/video/dialog

http://localhost:4533/libs/foundation/components/video/dialog.html

1345537_pastedImage_5.png

May be this is your environment and your custom listeners specific.

Avatar

Level 2

I think it is an issue in this specific environment. I will look into this.