Highlighted

Dialog on Package Manager UI does not close after success install

homerfv

18-06-2018

Hi Folks,

Has there anyone encounter this issue where in the package manager UI dialog (progress notification) does not close after installing a package successfully.

We are using AEM 6.3 and we encounter this issue only after we install SP2.

Appreciate if you can share your experience and how were you able to fix the issue.

Thanks,

Homer

Replies

Highlighted

kautuk_sahni

Community Manager

19-06-2018

Do you see some error in the dialog box/browser console or AEM error.log?

Can you try this on fresh instance as well?

-Kautuk

Highlighted

homerfv

19-06-2018

Hi Kautuk,

I cannot get relevant error message from the log file. The error.log file only shows the following during package install process.

20.06.2018 09:30:58.329 *INFO* [qtp9924585-12394] com.day.crx.packaging.impl.SlingInstallerSupportImpl Sling installer node /system/sling/installer/jcr/pauseInstallation/34ef381f-53a5-4b05-b43a-80d711768874/com.day.crx.packaging.impl.SlingInstallerSupportImpl/1c8d83f1-7bfe-49a6-8914-48961f782832 created.

20.06.2018 09:30:58.443 *INFO* [qtp9924585-12394] org.apache.jackrabbit.vault.packaging.impl.ActivityLog my_packages:test:1.0: INSTALL

20.06.2018 09:30:58.473 *INFO* [qtp9924585-12394] com.day.crx.packaging.impl.SlingInstallerSupportImpl Sling installer node /system/sling/installer/jcr/pauseInstallation/34ef381f-53a5-4b05-b43a-80d711768874/com.day.crx.packaging.impl.SlingInstallerSupportImpl/1c8d83f1-7bfe-49a6-8914-48961f782832 removed.

2018-06-20_094208.jpg

After waiting for about ~11 mins it closes and there is no error on browser console.

2018-06-20_095028.jpg

I did try in AEM 6.3 fresh install and does not have this issue. We only noticed this only after we installed the AEM6.3 SP2 package AEM-6.3.2.0-6.3.2.zip.

Any idea how to resolve this?

Thanks,

Homer

Highlighted

AEMDoc

19-06-2018

Hello  Homer,

The time it takes for the dialogue to disappear is tied to the contents of the package. For example, if you're installing a package that contains bundles, services or code that require some services and component to be restarted then the dialog will remain on the screen until all of such activities are completed. You can tail the error.log (crx-quickstart/logs/error.log) and monitor such activities in the logs.

If you are installing multiple packages with no interdependencies between them, you can simply refresh the page or just open another tab and go to the package manager to continue with the installation of those packages while the restart of bundles are services happen in the background. You can read more about this in the following older post:

CRX DE Package Starting System components message

I hope this helps!

Highlighted

homerfv

19-06-2018

Hi AEM.Doctor,

Thanks for the info. I agree that the package content/size is relevant on how long the UI dialog would appear while installing the package. I am just puzzled because no matter how big or small the package i try to install, the behavior is the same.

In fact, if you may refer to below image what i have tried installing contains only one JSP file.

2018-06-20_121444.jpg

Referring to the other post you have linked, im not sure though how this relevant to the issue i am facing as the package that that i have tried installing does not contain any ACS common code/content.

I have raised this issue #152532 to Daycare and Im still waiting for some advice.

Thanks,

Homer

Highlighted

smacdonald2008

20-06-2018

This is the proper route. If this shows up after you installed a service pack- then you need to check with support - which you have done. At this point - nothing more the community can do - we will close off this thread.