Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Deleting packages from crx-quickstart/install folder

prohira
Level 4
Level 4

We are running on AEM 6.1 SP2 CFP4. The way we installed SP2 and CFP4 was thru copying the zip packages into the install folder (this was recommended by Adobe because we were facing some issues while installing them thru package manager).

Now we are planning to upgrade to AEM 6.3. One of the note on Upgrading to AEM 6.3 says that "Packages in the install folder in the repository will be reinstalled after the upgrade.". I am wondering if upgrade process is going to re-install 6.1 SP2 + CFP4 packages after 6.3 upgrade. That sounds scary.

To try that, I deleted those packages from my local (from install folder) and it messed up my local instance.

Thanks, Pankaj

1 Accepted Solution
Jörg_Hoh
Correct answer by
Employee
Employee

Removing packages containing bundles from /install folder will always mess up your environment because of the way this uninstall (compared to the installation via package manager) works.

In your case I would recommend to raise a Daycare issue, because it's clearly something which needs to be fixed; either as part of the upgrade process or as part of the documentation.

Jörg

View solution in original post

7 Replies
Jörg_Hoh
Correct answer by
Employee
Employee

Removing packages containing bundles from /install folder will always mess up your environment because of the way this uninstall (compared to the installation via package manager) works.

In your case I would recommend to raise a Daycare issue, because it's clearly something which needs to be fixed; either as part of the upgrade process or as part of the documentation.

Jörg

View solution in original post

ssellath
Level 1
Level 1

Is this issue been fixed in any of the Cumulative Fix Packs.

We are experiencing the same issue, after removing some of the packages from the crx-quickstart/install folder the repository gets messed up and it even tries to uninstall some of the bundles.

It seems like a bug with  AEM assuming that the missing packages in the crx-quickstart/install folder has to be uninstalled.

Your response would be much appreciated.

Thanks

ssellath
Level 1
Level 1

Just to add more info - we are not upgrading - it's a clean AEM 6.2 instance with CFP4

AEM-6.2-Service-Pack-1-6.2.SP1.zip

cq-6.2.0-hotfix-12785-7.0

AEM-6.2-SP1-CFP4-4.0.zip

once you remove any of the packages after installing them the environment gets messed up.

Removing anything from the crx-quickstart/install folder just makes the environment messed up.

Jörg_Hoh
Employee
Employee

The basic principle is like this:

* dropping a file in a "supported format"  (content package, bundle, OSGI config in .config notation) into the /install folder will cause an installation of this file

* removing a file from the /install folder will cause a uninstallation of this file/package/...

uninstallation of a package will typically also delete all the content from the repository, which has been installed through it. If a content package comes with a bundle in /apps/myapp/install/mybundle-1.0.jar, then the mybundle will be uninstalled.

When a package A comes with subpackages B and C, uninstallation of A will cause the deletion of /etc/packages/B.zip and /etc/packags/C.zip, but not their uninstallation (at least that's the behaviour of the package manager, the OSGI Installer could try to be more clever; haven't tested it).

Servicepacks and hotfixes are rather complex packages, and removing them from the install folder (which is handled by code which is quite complex) should be done carefully.

In your case you should let that support figure it out for you.

Jörg

ssellath
Level 1
Level 1

Hi Jörg

AEM-6.2-Service-Pack-1-6.2.SP1.zip

cq-6.2.0-hotfix-12785-7.0

AEM-6.2-SP1-CFP4-4.0.zip

Thanks for your prompt response.

I can understand the significance of leaving packages inside the crx-quickstart/install folder, but every time we restart aem it actually trying to install those above three packages again, as in the crx/packmgr/ they are showing up on the top eventhough they were installed long back during the set up of the environment.

prohira
Level 4
Level 4

Hi ssellath,

That's not the behavior what I saw on my instances. I did restarted my instance couple of times but it never tried to re-install those again. I would suggest to create a daycare ticket.

Thanks.