Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Custom Components suddenly not appearing in Page Editor (Coral Is not defined)

I2obiNeire
Level 1
Level 1

I2obiNeire_0-1600872748201.png

Hey so I was editing and changing my stuff without issue. I came back the following day and suddenly was able to drop in my components into the SPA editor. I checked the console and started seeing this..

 

I'm using React with the aem-archetype and AEM 6.5.5 with the solr+http2 packages. My normal text component works fine, but everything else is failing

 

I have reinstalled everything. I have been updating cq:dialogs and models without issue beforehand with maven install and deploying the changes to my local running AEM. No matter what I reinstall or recheckout I still get the above issue.

 

The above to me looks like a missing dependency?

 

edit:

 

added the required depencies to the page policy and that seems to have resolved it

I2obiNeire_0-1600876176402.png

 

However this has not fixed my problem, I am now getting this message

I2obiNeire_1-1600876221552.png

 

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

1 Accepted Solution
I2obiNeire
Correct answer by
Level 1
Level 1

React code error, props were undefined

View solution in original post

0 Replies
I2obiNeire
Correct answer by
Level 1
Level 1

React code error, props were undefined

View solution in original post