Highlighted

Could not resolve dependencies for project com.adobe.training:company-core:bundle:0.0.1

Avatar

Avatar

coreym89078266

Avatar

coreym89078266

coreym89078266

19-06-2018

I am trying to run a mvn clean install and am getting this error message during the company-core installation:

[ERROR] Failed to execute goal on project company-core: Could not resolve dependencies for project com.adobe.training:company-core:bundle:0.0.1-SNAPSHOT: Failed

to collect dependencies at com.day.cq:cq-replication:jar:5.4.2: Failed to read artifact descriptor for com.day.cq:cq-replication:jar:5.4.2: Could not transfer

artifact com.day.cq:cq-replication:pom:5.4.2 from/to central (https://repo.maven.apache.org/maven2): Received fatal alert: protocol_version -> [Help 1]

I am unable to find a whole lot of documentation on this specific issue, so any help is much appreciated!

Thanks!

Replies

Highlighted

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K
smacdonald2008

19-06-2018

Are you building a custom project. Looks like in your POM - you are trying to reference a 3rd party JAR that is not part of the Adobe Repository. This is not an available bundle in the Adobe Repo - com.adobe.training:company-core:bundle

Highlighted

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K
smacdonald2008

19-06-2018

Are you following an artilce to build the OSGi bundle - if so - can you reference it please.

Highlighted

Avatar

Avatar

coreym89078266

Avatar

coreym89078266

coreym89078266

19-06-2018

I was trying to import the sample project that is referenced in the AEM 6.1 Back-End Development video course. Am i possibly running into issues because I am running AEM 6.4 and the videos are referencing AEM 6.1?

Highlighted

Avatar

Avatar

Arun_Patidar

MVP

Total Posts

2.9K

Likes

1.0K

Correct Answer

831

Avatar

Arun_Patidar

MVP

Total Posts

2.9K

Likes

1.0K

Correct Answer

831
Arun_Patidar
MVP

19-06-2018

Can you please try to make the changes in M2_HOME/conf/settings.xml like below

Creating an Adobe Experience Manager 6.3 Project using Adobe Maven Archetype 11

make sure profile should be active in settings.xml

<activation>

     <activeByDefault>true</activeByDefault>

</activation>

if you already have same changes try to run install command with  mvn clean install -Padobe-public

Thanks

Arun