Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Copy entire website from Adobe CQ in one server to a Adobe CQ on a test server

Avatar

Level 6

I used Package Manager to download the content from Adobe CQ5 and imported it to the test server. Also downloaded and uploaded Digital Assets.

The question is how do I get the webpages? After the content was imported I don't see in WCM any pages of the project.

1 Accepted Solution

Avatar

Correct answer by
Level 10

Please ensure that package you downloaded is having filter similar to /content/ [project name].

If not create a new package with this filter. Pages of websites are created under /content path, download it and install at your new server

View solution in original post

0 Replies

Avatar

Employee

Hi,

Did you use [1] in order to create your package?

You need to copy the assets and the site from under /content/yourapp You also need to deploy your codebase to your new server.

When you say "how do I get the webpages", what do you mean? Can you not see the imported content in the new aem instance? Can you not use the same content url's by replacing the server name?

Regards,

Opkar

 

[1]http://docs.adobe.com/docs/en/aem/6-0/administer/content/package-manager.html

Avatar

Level 10
Its seems you need to replicate these users as well. You publish instance should have all required data. Users are store under node /home. Please chk

Avatar

Level 6

I imported the users, passed the login with the user. but ....

after the login screen all the other pages are returning 404 error.

I read about Dispatcher , should i really install Apache?

Avatar

Level 1

Hi

There is an alternate way to do that instead of package manager you could start your test server, go to crxde then tools and then import site. There specify the url and import full site.

Avatar

Level 6

hi Opkar

thank you for responding to me.

I am very new to Adobe CQ. I used Package Exporter to download a zip file was already there, I imported it to the new server.

by meaning that i don't get webpages, means that in CQ5 WCM I don't see the website of the project, only the Geometrics.

 Should I use additional filters to get everything from the website?

Xena.

Avatar

Level 6

oh.. I always forget to replicate the package. thank you...

Avatar

Level 6

I tried that and it copied a web page as a new project but without its children pages.

Avatar

Level 6

Xena_bcn wrote...

I used Package Exporter to download a zip file was already there, I imported it to the new server.

 

 

This means: in the Package manager I found a zip file with the website name and recent date and generated by the admin. I am not an admin. So I thought it is a backup of the website. So I downloaded it and then uploaded to the test server. I didn't create any new package.

Avatar

Correct answer by
Level 10

Please ensure that package you downloaded is having filter similar to /content/ [project name].

If not create a new package with this filter. Pages of websites are created under /content path, download it and install at your new server

Avatar

Level 6

Thank you very much,. I will build a new package with this filter then.

 

Xena.

Avatar

Level 6

THANK YOU A LOT TO BOTH OF YOU!

you made my day... Now I got the website!

I was very upset before.

Have a nice day...

Avatar

Community Advisor

Best and preferred way of doing is using 'Package Manager' as

1. you can track what has been installed and you can revoke easily

2. you can package all the content required at once

Avatar

Level 10

Make sure you Build the package after adding filter and before downloading it. 

It should be similar to this image.

[img]Content Package.png[/img]

Avatar

Level 6

hi, it is me again. sorry.

 

So the website on the test server is up... Thank you for all your  help.

The current question is I have a user who logs in to the website private area. I imported the users with help of the Package Manager.  In the siteadmin I see the users I imported. 

But in publish instance when I try to log in with this user, I can't...