Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Content Fragment - Validation Error Message - Not showing up

Avatar

Level 3

Hi, 

 

Setting up content fragment property "required=true" for id and fragment path field in the CF component.
Client side validation working as expected on submit of blank field and getting the error icon, but validation error message is not showing up on hover of mouse on the icon.

Not sure whether it is a bug, or any missing configuration.

 

Any suggestion is welcome..

val_error_1.pngcf_validation_error.png

error_code.png

AEM 6.5.4 and CS

 

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hi @NitinL ,

 

Could you please check once in vanilla instance. If this issue still exists please raise this concern to support team.

 

And I believe this issue is not only applicable to Content Fragment component required fields but for all the Component fields wherever required property is used.

View solution in original post

4 Replies

Avatar

Community Advisor

Hi @NitinL ,

                         Did you checked content fragment model for validation message. Please go through the below link for more information.

https://experienceleague.adobe.com/docs/experience-manager-65/assets/content-fragments/content-fragm...

Avatar

Level 3

thanks @Sanjay_Bangar , my questions is about CF component, not about the CF model.

What exactly do you want me to look into CF model, can you please point it out.. ??

Avatar

Correct answer by
Community Advisor

Hi @NitinL ,

 

Could you please check once in vanilla instance. If this issue still exists please raise this concern to support team.

 

And I believe this issue is not only applicable to Content Fragment component required fields but for all the Component fields wherever required property is used.

Avatar

Level 3

Thanks @Kishore_Kumar_ , yep your observation is correct for required field validation. Already raised the ticket and asked the same here as well, many a times we get faster response on a query here in the forum then Adobe day care support team.