Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Content did not save in classic to touch UI converted dialog

Nandujee
Level 3
Level 3

Hello experts,

We are moving our application from classic to touch UI, post the conversion this would be converted to SPA.

AEM modernization tool is used to convert from classic to touch UI dialog, after conversion, the dialog opens properly. However, the modified information is not stored. 

There're few calls noticed on the network tab and see the updated content on the call but still, the information is not stored in CRX/de.

Note: I'm using AEM 6.5

 

 

Any suggestion?

 

Thank you

Nanda

1 Accepted Solution
Nandujee
Correct answer by
Level 3
Level 3

Thanks for the response. 

The issue had been identified, I moved the file"/apps/cq/xssprotection/config.xml" to the temp folder and it's resolved the issue. 

 

View solution in original post

3 Replies
Dipti_Chauhan
Community Advisor
Community Advisor

Hi @Nandujee 

  Please validate your dialog post request, form data and response again. May be some issue with post

 

Thanks

Dipti

markus_bulla_adobe
Employee
Employee

Hi @Nandujee!

While the AEM modernization tools can give you a good starting point for moving from Classic to Touch UI, they are not a full automation for dialog conversion. In my experience, they work pretty well and with almost no need for manual rework for simple dialogs. However, for more complex dialogs - especially if they include nesting and custom or customized field types and similar - the result will often need some manual adjustments to work properly.

 

So my advise is to double check on the resulting dialog definition and validate that everything looks as expected.

If you need advice in doing so or if everything looks good but persisting values still does not work, please share the dialog definition(s) in question - ideally both, for Classic and Touch UI.

 

Hope that helps!

 

Nandujee
Correct answer by
Level 3
Level 3

Thanks for the response. 

The issue had been identified, I moved the file"/apps/cq/xssprotection/config.xml" to the temp folder and it's resolved the issue. 

 

View solution in original post