Components have disappeared

Avatar

Avatar

malissas1679627

Avatar

malissas1679627

malissas1679627

11-07-2016

Hello, 

I was working on a new page when all of the components in the AEM floating toolbox disappeared. I even tried to Right click on a component section and add a new component but I still have no components to select. I have closed my browers and cleared my cache and even tried another browser but nothing will help.

Would really appreciate any help since I cannot build any pages at this point.

Thanks - Malissa

 

Replies

Avatar

Avatar

bsloki

MVP

Avatar

bsloki

MVP

bsloki
MVP

11-07-2016

Goto the design mode and add the component group. Come back to edit mode and you should be able to see the components

Avatar

Avatar

bsloki

MVP

Avatar

bsloki

MVP

bsloki
MVP

11-07-2016

If it was available before and then kind of disappeared, then check if you are seeing any error in your browser.

Avatar

Avatar

kautuk_sahni

Community Manager

Total Posts

5.8K

Likes

1.0K

Correct Reply

1.1K

Avatar

kautuk_sahni

Community Manager

Total Posts

5.8K

Likes

1.0K

Correct Reply

1.1K
kautuk_sahni
Community Manager

12-07-2016

Hi 

As mentioned by Lokesh, if the components were coming earlier and missing now, then please check the browser logs and AEM error.log.

 

Else

 

Please follow the steps mentioned below :-

By default, the sidekick doesn’t display the newly created components. You need to enable them explicitly in a CQ author instance.

Create the component.
Using SiteAdmin, open the page that you want to edit in the Author instance.
From the sidekick, click the Design tab.
In the Design of Paragraph tab that appears, click Edit.

Find the component based on the ComponentGroup property you defined and enable it.

This is how you can add the components.


Link:- http://blogs.adobe.com/sunil/2013/06/05/displaying-the-newly-created-component-in-the-sidekick-of-ad...

I hope this would help you.

Thanks and Regards

Kautuk Sahni

Avatar

Avatar

malissas1679627

Avatar

malissas1679627

malissas1679627

12-07-2016

When I try to do this, clicking on Design in the sidekick makes it roll-up so I can't do anything else. I have restarted my PC and I have no browser errors. The components I was using are not new and they have been used to build a few of our websites (created for us by an outside agency who helped set up AEM). 

Any other ideas?

Avatar

Avatar

bsloki

MVP

Avatar

bsloki

MVP

bsloki
MVP

12-07-2016

Once you go to the design mode, you will see a parsys edit bar, click on that to add the components.

If you dont have the parsys in your page, then pls contact the developer to help you out !

Avatar

Avatar

courtthreeGDC

Avatar

courtthreeGDC

courtthreeGDC

12-07-2016

Hey Malissa,

I've seen this happen many times when my client has accidentally put a component in "Target" mode. It's easily done becuse if you have the edit button in view at the top of a component, the client can accidentally hit "Target" instead!

Do you have access to the CRX (in CRXDE Lite) so we can verify if this is the case? If you do, drill down to the offending page in the content node of the CRX and you will likely see a node in there called "default" which contains the component that has been mistakenly targeted.

Let mw know if you can access it and whether what I've said rings true and I'll explain how to fix it.

Avatar

Avatar

umeshj24393

Avatar

umeshj24393

umeshj24393

28-11-2017

Hi courtthreeGDC ,

It is true when i click on target button in External component in AEM , Side kick gets empty.

I also verified in crx/de. can you explain how to fix it?

Thanks