Accepted Solutions (1)

Accepted Solutions (1)

Andrew_Khoury

Employee

21-05-2019

rajs73651622​ I see the problem, that article you referenced is outdated.  The class has been moved from

cq-dam-core bundle to cq-dam-commons, see here AbstractAssetHandler

Also, I would suggest using the uber-jar for your AEM version instead of using separate dependencies.  See here for how to set up a proper project:

How to Build AEM Projects using Apache Maven

Answers (9)

Answers (9)

rajs73651622

20-05-2019

Hi Joerg,

Thanks for looking into this issue.

I am following the below link to develop a text handler but there r some changes to text handler as per our requirement .

Processing Assets Using Media Handlers and Workflows .

Here in the above link in pom.xml  it is used the blow version but in "http://repo.adobe.com/nexus/content/groups/public/"

the below version is not available so i used <version>5.3.0</version>.

          <dependency>

            <groupId>com.day.cq.dam</groupId>

            <artifactId>cq-dam-core</artifactId>

            <version>5.2.10</version>

            <scope>provided</scope>

        </dependency>

Regards,

Raj

Jörg_Hoh

Employee

20-05-2019

Thanks!

Looks like there is no specific import version listed. But: My local AEM 6.4 instance does not export that Java package "com.day.cq.dam.core" at all (in no version). That explains at least the behavior of your AEM instance.

But that leaves the question: How do you create such a MANIFEST.MF? Do you port the code from an older AEM version to AEM 6.4? Was it running there properly? And then you might check that you don't have such import statements hardcoded in your pom.xml

Jörg

rajs73651622

20-05-2019

Below is the MANIFEST.MF file

Export-Package: com.aem.community.core.filters;uses:="javax.servlet";ver

sion="1.0.0",com.aem.community.core.listeners;uses:="org.osgi.service.e

vent";version="1.0.0",com.aem.community.core.models;uses:="javax.annota

tion,javax.inject,org.apache.sling.api.resource,org.apache.sling.models

.annotations";version="1.0.0",com.aem.community.core;version="1.0";uses

:="com.day.cq.dam.api.metadata,com.day.cq.dam.core,javax.jcr",com.aem.c

ommunity.core.schedulers;version="1.0.0",com.aem.community.core.servlet

s;uses:="javax.servlet,org.apache.sling.api,org.apache.sling.api.servle

ts";version="1.0.0"

Import-Package: javax.inject;version="0.0.0",com.day.cq.dam.api.metadata

;version="[1.1,2)",com.day.cq.dam.core,com.day.cq.wcm.foundation;versio

n="[5.21,6)",com.day.image;version="[1.0,2)",com.day.image.font;version

="[1.0,2)",javax.annotation,javax.jcr;version="[2.0,3)",javax.servlet,o

rg.apache.commons.io;version="[1.4,2)",org.apache.sling.api;version="[2

.3,3)",org.apache.sling.api.request;version="[2.4,3)",org.apache.sling.

api.resource;version="[2.10,3)",org.apache.sling.api.servlets;version="

[2.2,3)",org.apache.sling.models.annotations;version="[1.4,2)",org.apac

he.sling.settings;version="[1.3,2)",org.osgi.service.event;version="[1.

3,2)",org.slf4j;version="[1.5,2)"

Provide-Capability: osgi.service;objectClass:List<String>="java.lang.Run

nable",osgi.service;objectClass:List<String>="javax.servlet.Filter",osg

i.service;objectClass:List<String>="javax.servlet.Servlet",osgi.service

;objectClass:List<String>="org.osgi.service.event.EventHandler"

Require-Capability: osgi.extender;filter:="(&(osgi.extender=osgi.compone

nt)(version>=1.3.0)(!(version>=2.0.0)))",osgi.ee;filter:="(&(osgi.ee=Ja

vaSE)(version=1.8))"

Service-Component: OSGI-INF/com.aem.community.core.filters.LoggingFilter

.xml,OSGI-INF/com.aem.community.core.listeners.SimpleResourceListener.x

ml,OSGI-INF/com.aem.community.core.schedulers.SimpleScheduledTask.xml,O

SGI-INF/com.aem.community.core.servlets.SimpleServlet.xml

Sling-Model-Packages: com.aem.community.core

Tool: Bnd-3.3.0.201609221906

Jörg_Hoh

Employee

19-05-2019

Can you provide us the complete MANIFEST.MF file of that bundle? It should include the package version of the dam.core bundle which has been used during compilation.

rajs73651622

17-05-2019

I m using the below dependency to uber jar for AEM 6.4.

<dependency>

    <groupId>com.adobe.aem</groupId>

    <artifactId>uber-jar</artifactId>

    <version>6.4.0</version>

    <classifier>apis</classifier>

    <scope>provided</scope>

</dependency>

jbrar

Employee

17-05-2019

Check if you are using the latest uber jar. For Example, If this is AEM 6.5, make sure you are using the following dependency:

<!-- https://mvnrepository.com/artifact/com.adobe.aem/uber-jar -->

<dependency>

    <groupId>com.adobe.aem</groupId>

    <artifactId>uber-jar</artifactId>

<version>6.5.0.0</version>

    <type>pom</type>

    <scope>provided</scope>

</dependency>