Expand my Community achievements bar.

Radically easy to access on brand approved content for distribution and omnichannel performant delivery. AEM Assets Content Hub and Dynamic Media with OpenAPI capabilities is now GA.
SOLVED

com.adobe.cq.wcm.core cannot find the simbol

Avatar

Level 2

Hi Team,

 

I'm not sure which Archetype the current project is using but whenever I want to extend a core component, It doesn't detect the package. 

Screenshot 2024-02-29 at 10.42.12.png

Screenshot 2024-02-29 at 10.38.39.png

 

I'm not sure if this is because uber-jar (currently 6.5.12) is not compatible with the core components the project has (2.20) or some other dependencies. 

 

the pom.xml doesn't have any dependency for the core components  

 

Screenshot 2024-02-29 at 10.52.28.png

 

This is the first time I'm facing an issue like this so I've checked other post from the Adobe community but didn't work. You're inputs will be a great guidance to me in order to figure out the issue. 

Regards

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

in IDE try Maven Reload Project / Generate Sources

check your settings.xml also - adobe public repository

View solution in original post

8 Replies

Avatar

Community Advisor

You need to add core.wcm.components.core dependency to your root and core pom.xml

<dependency>
  <groupId>com.adobe.cq</groupId>
  <artifactId>core.wcm.components.core</artifactId>
  <version>${core.wcm.components.version}</version>
</dependency>

 

Avatar

Level 2

Hi, @Mahedi_Sabuj  I already added core.wcm.components.core to pom.xml and core.xml but the issue persists.

Avatar

Community Advisor

Sometimes IDE needs to restart for new dependency taking any effect. Could you please restart your IDE and try again?

Avatar

Correct answer by
Community Advisor

in IDE try Maven Reload Project / Generate Sources

check your settings.xml also - adobe public repository

Avatar

Level 2

Hi Guys, I tried your suggestions but none of them are working.

 

Parent  POM

Screenshot 2024-02-29 at 13.10.59.png

 

Core POM

Screenshot 2024-02-29 at 13.11.21.png

Example Class

Screenshot 2024-02-29 at 13.12.34.png

Avatar

Community Advisor

do you have any VPN or Proxy enabled?

 

can you check in any other project or try wknd GitHub project - if the same issue ?

 

https://github.com/adobe/aem-guides-wknd/blob/main/pom.xml

Avatar

Level 10

@Luis_Ochoa In Intellij, right click on the project root folder -> maven and click on Reload Project and check if any build error is coming. It is not able to download dependency if I am not wrong. please confirm if it says Could not find artifact

Avatar

Level 2

Disregard Guys. I was able to get this fixed. I'm not sure which button I pressed from my IDE but it know works. 

 

Appreciate all the help you gave me !!