Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

com.adobe.cq.commerce.api,version=[1.1,2) -- Cannot be resolved

wmakend
Level 2
Level 2

I installed a bundle to test the price for an ecommerce site. When I export my bundle I can not turn it on because he always tells me the error of the above(com.adobe.cq.commerce.api,version=[1.1,2) -- Cannot be resolved).

 

Log:

at java.lang.Thread.run(Unknown Source)
01.12.2015 09:35:45.334 *INFO* [OsgiInstallerImpl] org.apache.sling.installer.core.impl.tasks.BundleStartTask Could not start bundle com.adobe.training.commerce-training-bundle [447]. Reason: {}. Will retry.
org.osgi.framework.BundleException: Unresolved constraint in bundle com.adobe.training.commerce-training-bundle [447]: Unable to resolve 447.3: missing requirement [447.3] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.cq.commerce.api)(version>=1.1.0)(!(version>=2.0.0)))
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4095)
    

Thanks

Willy

1 Accepted Solution
kautuk_sahni
Correct answer by
Community Manager
Community Manager

Hi 

As mentioned my Tomar, this is bundle version mismatch problem.

The Version used in dependency is not available in AEM Console.

//To check go to http://localhost:4502/system/console/depfinder , then search for com.adobe.cq.commerce.api, there you can get version number.

Please check the Version available in Web Console and change the dependency version accordingly.

I hope this would help you.

Thanks and Regards

Kautuk Sahni

View solution in original post

8 Replies
Jitendra_S_Toma
Level 9
Level 9

It seems to me, it is a bundle version mismatch. In bundle dependency, you might have used a different version, which is not available in AEM console.

What is the AEM version? And Did you verify version of com.adobe.cq.commerce.api in apache felix?. 

--

jitendra

wmakend
Level 2
Level 2

It seems to me, it is a bundle version mismatch. In bundle dependency, you might have used a different version, which is not available in AEM console.

Yes, it is possible

What is the AEM version?

6.0

And Did you verify version of com.adobe.cq.commerce.api in apache felix?. 

Attached

                                     
Symbolic Namecom.adobe.cq.commerce.cq-commerce-core
Version5.13.12
Bundle Locationjcrinstall:/libs/commerce/install/cq-commerce-core-5.13.12.jar
Last ModificationMon Nov 30 16:04:54 CET 2015
Bundle Documentationhttp://www.adobe.com/
VendorAdobe Systems Incorporated
DescriptionAdobe CQ Commerce API and common classes
Start Level20
Exported Packagescom.adobe.cq.commerce.api,version=3.1.0
com.adobe.cq.commerce.api.asset,version=1.0.0
com.adobe.cq.commerce.api.collection,version=1.1.0
com.adobe.cq.commerce.api.promotion,version=1.2.1
com.adobe.cq.commerce.common,version=3.4.0
com.adobe.cq.commerce.common.promotion,version=1.2.0

 

in my Maven 

        <dependency>
            <groupId>com.adobe.cq.commerce</groupId>
            <artifactId>cq-commerce-core</artifactId>
            <version>5.6.8</version>
            <scope>provided</scope>
        </dependency>

from 

 

Thank

--

Willy

kautuk_sahni
Correct answer by
Community Manager
Community Manager

Hi 

As mentioned my Tomar, this is bundle version mismatch problem.

The Version used in dependency is not available in AEM Console.

//To check go to http://localhost:4502/system/console/depfinder , then search for com.adobe.cq.commerce.api, there you can get version number.

Please check the Version available in Web Console and change the dependency version accordingly.

I hope this would help you.

Thanks and Regards

Kautuk Sahni

View solution in original post

Ameen_Dev
Level 1
Level 1
I followed your method but I didn't find the dependencies in POM file. So I added the dependency manually and saved the POM file. Now how do I update the entire project? Please help me
DEBAL_DAS
Level 4
Level 4

Hi Kautuk,

 

I am facing same issue with AEM 6.2 and  have captured the details from web console -

     
Imported Packagescom.adobe.cq.commerce.api,version=[1.2,2) -- Cannot be resolved
com.adobe.cq.commerce.api.promotion,version=[1.2,2) from com.adobe.cq.commerce.cq-commerce-core (225)
com.adobe.cq.commerce.common,version=[1.2,2) -- Cannot be resolved

I have checked depfinder as well and got the info -

<dependency>

<groupId>com.adobe.cq.commerce</groupId>

<artifactId>cq-commerce-core</artifactId>

<version>5.14.102</version>

<scope>provided</scope>

</dependency>

and geometrixx has following dependency - <dependency>
            <groupId>com.adobe.cq.commerce</groupId>
            <artifactId>cq-commerce-core</artifactId>
            <version>5.14.22</version>
            <scope>provided</scope>
        </dependency>

 

But, when I checked in https://repo.adobe.com/nexus/content/groups/public/com/adobe/cq/commerce/cq-commerce-core/, i couldn't get any bundle with version 5.14.XX.

Please have a look and suggest.

 

Thanks,

Debal

gauravs23
Level 2
Level 2

Hi Debal,

The commerce jar version 5.14.102 is not available in any of the public repositories, however you can get it if you extract AEM jar on your local machine. Then just install the commerce core jar in your local maven repository and it will start working. Let me know in case you still face issues.

In AEM 6.3, there is no need to explicitly add this dependency as it is already managed by uber-jar, however it AEM 6.2, I had to explicitly add the dependency as well as jar to my local maven repo.

Thanks,

Gaurav