Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Cloud Manager Deployment - Content Package not getting deployed

Avatar

Level 4

Hi Team,

We are using ACS as a cloud service and deployed build on the higher (stage) env using cloud manager. The build is successful but the content package is not getting deployed. There is no error in the log file and this same build including the content package was successfully deployed in the lower (dev) env. I also investigated the build deployment logs and could notice that our content package was part of the "all" package but I am unable to figure out why it is not deployed.

 

Any pointers or suggestions would be helpful.

Thanks,

Manpreet

1 Accepted Solution

Avatar

Correct answer by
Employee Advisor

You should raise a ticket with the Adobe support, because it would require access to the logs (plus context) to troubleshoot this. But technically there is no difference in the deployment behavior here between DEV and Stage/Prod.

View solution in original post

4 Replies

Avatar

Correct answer by
Employee Advisor

You should raise a ticket with the Adobe support, because it would require access to the logs (plus context) to troubleshoot this. But technically there is no difference in the deployment behavior here between DEV and Stage/Prod.

Avatar

Level 2

we have the same issue as well. The package ui.apps and ui.content are uploaded to publish instances but NOT INSTALLED. but this is not happening in QA environment and prod. Untill last release it started happening in production as well. we even raised an adobe support ticket, not much help from them.  Could you please let me know how did you resolve. 

 

note:

we are using cloud manager non-production pipeline to build and deploy on stage. The Stage environment is non-production for us and we have  preprod and prod as part of production pipeline. 

We are using 0.0.1-SNAPSHOT in the pom. We didn't want to maintain any versions

project created based on maven archetype 33

Avatar

Level 2

logs from publish instance:

 

04.08.2022 18:55:22.255 *INFO* [qtp1485593154-106872] com.day.crx.packaging.impl.SlingInstallerSupportImpl Sling installer node /system/sling/installer/jcr/pauseInstallation/884f121e-ff99-4c10-bfc6-d59c02a0b716/com.day.crx.packaging.impl.SlingInstallerSupportImpl/3c0687c8-f6a1-4be5-9c34-d5120c4b4069 created.
04.08.2022 18:55:22.352 *INFO* [qtp1485593154-106872] com.day.crx.packaging.impl.J2EEPackageManager Found installable at /apps/xxx-packages/application/install/xxx-xx-xx.core-0.0.1-SNAPSHOT.jar/jcr:content
04.08.2022 18:55:22.940 *INFO* [qtp1485593154-106872] org.apache.jackrabbit.vault.packaging.impl.ActivityLog com.xx:xxx-xxx.all:0.0.1-SNAPSHOT: INSTALL
04.08.2022 18:55:22.946 *INFO* [qtp1485593154-106872] com.day.crx.packaging.impl.SlingInstallerSupportImpl Sling installer node /system/sling/installer/jcr/pauseInstallation/884f121e-ff99-4c10-bfc6-d59c02a0b716/com.day.crx.packaging.impl.SlingInstallerSupportImpl/3c0687c8-f6a1-4be5-9c34-d5120c4b4069 removed.
04.08.2022 18:55:22.946 *INFO* [qtp1485593154-106872] com.day.crx.packaging.impl.J2EEPackageManager Scanner detected potential jcr installable. delaying installation for 2 seconds.
04.08.2022 18:55:22.995 *INFO* [JcrInstaller.1] org.apache.sling.installer.provider.jcr.impl.JcrInstaller Registering resource with OSGi installer: [InstallableResource, priority=200, id=/apps/xxx-packages/application/install/xxx-xx-xx.ui.apps-0.0.1-SNAPSHOT.zip, InstallableResource, priority=200, id=/apps/xxx-packages/application/install/xxx-xx-xx.ui.config-0.0.1-SNAPSHOT.zip, InstallableResource, priority=200, id=/apps/xxx-packages/application/install/xxx-xx-xx.core-0.0.1-SNAPSHOT.jar]
04.08.2022 18:55:23.051 *INFO* [JcrInstaller.1] org.apache.sling.installer.provider.jcr.impl.JcrInstaller Registering resource with OSGi installer: [InstallableResource, priority=200, id=/apps/xxx-packages/content/install/xxx-xx-xx.ui.content-0.0.1-SNAPSHOT.zip]
04.08.2022 18:55:23.898 *INFO* [OsgiInstallerImpl] org.apache.jackrabbit.vault.packaging.impl.ActivityLog com.xx:xxx-xxx.ui.apps:0.0.1-SNAPSHOT: CREATE
04.08.2022 18:55:23.898 *INFO* [OsgiInstallerImpl] org.apache.jackrabbit.vault.packaging.impl.ActivityLog com.xx:xxx-xxx.ui.apps:0.0.1-SNAPSHOT: UPLOAD
04.08.2022 18:55:23.968 *INFO* [OsgiInstallerImpl] org.apache.jackrabbit.vault.packaging.impl.ActivityLog com.xx:xxx-xxx.ui.apps:0.0.1-SNAPSHOT: EXTRACT_SUB_PACKAGES ()
04.08.2022 18:55:23.977 *INFO* [OsgiInstallerImpl] org.apache.jackrabbit.vault.packaging.impl.ActivityLog com.xx:xxx-xxx.ui.config:0.0.1-SNAPSHOT: CREATE
04.08.2022 18:55:23.977 *INFO* [OsgiInstallerImpl] org.apache.jackrabbit.vault.packaging.impl.ActivityLog com.xx:xxx-xxx.ui.config:0.0.1-SNAPSHOT: UPLOAD
04.08.2022 18:55:23.997 *INFO* [OsgiInstallerImpl] org.apache.jackrabbit.vault.packaging.impl.ActivityLog com.xx:xxx-xxx.ui.config:0.0.1-SNAPSHOT: EXTRACT_SUB_PACKAGES ()
04.08.2022 18:55:24.079 *INFO* [OsgiInstallerImpl] org.apache.jackrabbit.vault.packaging.impl.ActivityLog com.xx:xxx-xxx.ui.config:0.0.1-SNAPSHOT: INSTALL
04.08.2022 18:55:24.079 *INFO* [OsgiInstallerImpl] org.apache.sling.audit.osgi.installer TaskResource(url=jcrinstall:/apps/xxx-packages/application/install/xx-xxx.ui.config-0.0.1-SNAPSHOT.zip, entity=content-package:com.xx:xxx-xxx.ui.config, state=INSTALL, attributes=[org.apache.sling.installer.api.tasks.ResourceTransformer=:7724:7763:7764:25:19:2002:, package-id=com.xx:xxx-xxx.ui.config:0.0.1-SNAPSHOT, Bundle-Version=0.0.1.SNAPSHOT], digest=1659639322564): content package installed

Avatar

Employee Advisor

Is this Cloud Service or AMS? I assume AMS, as the deployment paths for the ZIP files are not in /apps.

 

Unfortunately I don't know the CM for AMS 😞