Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.

Clientlibs donot get updated

Avatar

Level 1

We have been facing issues with Clientlibs update. Every time we push new changes to the existing clientlibs, after deployment , it still shows the older one. We are using AEM as cloud, and have tried rebuilding the Clientlibs/clearing the clientlib cache(/libs/granite/ui/content/dumplibs.rebuild.html), but this doesnt work.
The workaround is to always update new category name for the client lib, and thus it identifies a new client lib altogether when deployed.

Isn't AEM already versioning and rebuilding clientlibs. Any support please.

 

4 Replies

Avatar

Community Advisor

@lipishree 

Versioned/serialized hash URL is enabled/available by default in all cloud service environments. The same is updated when the underlying CSS/JS is changed. 

Could you please 

  • cross check the clientlib URL as included in the page before and after deployment. 
  • check the changes in Incognito after deployment 

Avatar

Community Advisor

Same issue and tried the methods which you mentioned above but no success.

Himanshu Jain

Avatar

Community Advisor

Check which specific clientlib version is creating issue .

Also check the special character in that particular css files ( check formatting) .

Hope it will help.

Himanshu Jain

Avatar

Employee Advisor

As per my understanding, the issue is happening because clientllibs are not recompiled at the later stage of the deployment. When the clientlib is compiling it will look for the included CSS file.

 

Here you can try below: 

 

-->The first approach, avoid deleting the CSS files at the initial deployment by excluding the file paths in filter.xml. 

 

-->The second approach is to include the clientlib along with the CSS files in the later stage of the deployment. Hope this resolves your issue.