Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Can we use the Archetype 22 for AEM version 6.4.2?

ramaem12
Level 2
Level 2

Currently, we are in 6.4.2, and we are adding a new repo to the instance. We are planning for the AEM instance upgrade to 6.4.6 or .8 in the future( not yet decided for timeline). After building the project, we intended to all core components( because every archetype tied with diff versions- archetype 22 comes with 2.7.0 and my env using 2.5.0) dependencies from the code.

when i compare 2 pom.xml's, archetype 22 is creating extra all folder in the structure and below are the few differences present in remaining pom.xml files-

<plugin>
<groupId>biz.aQute.bnd</groupId>
<artifactId>bnd-maven-plugin</artifactId>
<version>${bnd.version}</version>
</plugin>

<dependencies>
<dependency>
<groupId>org.apache.sling</groupId>
<artifactId>org.apache.sling.caconfig.bnd-plugin</artifactId>
<version>1.0.2</version>
</dependency>
</dependencies>

<dependency>
<groupId>javax.annotation</groupId>
<artifactId>javax.annotation-api</artifactId>
</dependency>

Can we use archetype 22?

1 Accepted Solution
Theo_Pendle
Correct answer by
Community Advisor
Community Advisor

Hi @ramaem12

The Maven Archetype version has very little to do with the AEM version. The only critical elements are:

Here are the requirements for the 22 version:

 

Requirements

The latest version of the archetype has the following requirements:

  • Adobe Experience Manager 6.3.3.0 or higher
  • Apache Maven (3.3.9 or newer)
  • Adobe Public Maven Repository in maven settings, see Knowledge Base article for details.

View solution in original post

4 Replies
Theo_Pendle
Correct answer by
Community Advisor
Community Advisor

Hi @ramaem12

The Maven Archetype version has very little to do with the AEM version. The only critical elements are:

Here are the requirements for the 22 version:

 

Requirements

The latest version of the archetype has the following requirements:

  • Adobe Experience Manager 6.3.3.0 or higher
  • Apache Maven (3.3.9 or newer)
  • Adobe Public Maven Repository in maven settings, see Knowledge Base article for details.

View solution in original post

hamidk92094312
Employee
Employee

To be on the safe side you can see a list of supported AEM versions of historical archetype versions:

https://github.com/adobe/aem-project-archetype/blob/master/VERSIONS.md

ramaem12
Level 2
Level 2
Thanks for the link but if i am not using core components from code base, can i use the archetype 22?
hamidk92094312
Employee
Employee
Per the shared doc archetype 22 is supported in AEM 6.4 so I do not see why you can not use it ...