Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Can not create new AEM project. The wizard will fail to popup. [Eclipse show :This step defines which server to use with the new project.]

starkc18095558
Level 1
Level 1

I have installed and configure Eclipse AEM plugin. Then start to create a new AEM project by eclipse. But always failed.

I find some same issue on stackoverflow.

http://stackoverflow.com/questions/28556085/aem-eclipse-plugin-new-project-creation-issue

I found some error log as below:

OS Environmen: Window 7 enterprise 64bit

JDK: 1.8.0_121

Maven: 3.3.9

Installed AEM plugin, online and offline both to have tried: com.adobe.granite.ide.p2update-1.1.0.zip (from https://eclipse.adobe.com/aem/dev-tools/)

Tried to add archetype by manual, local and remote both to have tried. (from https://repo.adobe.com/nexus/content/groups/public/archetype-catalog.xml)

Eclipse: Luna, Neon both to tired, both failed.

Eclipse show :This step defines which server to use with the new project. can not process to wizard

Eclipse error log:

eclipse.buildId=4.6.0.I20160606-1100
java.version=1.8.0_121
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_SG
Framework arguments:  -product org.eclipse.epp.package.jee.product
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.jee.product

org.eclipse.ui
Error
Fri Apr 28 15:29:23 SGT 2017
Unhandled event loop exception

java.lang.RuntimeException: Could not process archetype: null
    at com.adobe.granite.ide.eclipse.ui.wizards.np.AdvancedSettingsComponent.initialize(AdvancedSettingsComponent.java:267)
    at com.adobe.granite.ide.eclipse.ui.wizards.np.SimplerParametersWizardPage.setVisible(SimplerParametersWizardPage.java:160)
    at org.eclipse.jface.wizard.WizardDialog.updateForPage(WizardDialog.java:1215)
    at org.eclipse.jface.wizard.WizardDialog.lambda$2(WizardDialog.java:1185)
    at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
    at org.eclipse.jface.wizard.WizardDialog.showPage(WizardDialog.java:1185)
    at org.eclipse.jface.wizard.WizardDialog.nextPressed(WizardDialog.java:876)
    at org.eclipse.jface.wizard.WizardDialog.buttonPressed(WizardDialog.java:419)
    at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.java:618)
    at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:249)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4410)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4228)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3816)
    at org.eclipse.jface.window.Window.runEventLoop(Window.java:818)
    at org.eclipse.jface.window.Window.open(Window.java:794)
    at org.eclipse.ui.actions.NewProjectAction.run(NewProjectAction.java:115)
    at org.eclipse.jface.action.Action.runWithEvent(Action.java:473)
    at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:565)
    at org.eclipse.jface.action.ActionContributionItem.lambda$4(ActionContributionItem.java:397)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4410)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4228)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3816)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:687)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:604)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:138)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: java.lang.NullPointerException
    at com.adobe.granite.ide.eclipse.ui.wizards.np.AdvancedSettingsComponent.initialize(AdvancedSettingsComponent.java:253)
    ... 46 more

When I try to use command line to create, it succeed. I don't know why eclipse have this issue. Who can help me?

1 Accepted Solution
kautuk_sahni
Correct answer by
Community Manager
Community Manager

I think the plugin has the problem, if you Click cancel and then run a build from console and them add to the server in eclipse, it will work.

Go to root of your project and run the maven command: mvn -PautoInstallPackage -PintegrationServer install

~kautuk

View solution in original post

1 Reply
kautuk_sahni
Correct answer by
Community Manager
Community Manager

I think the plugin has the problem, if you Click cancel and then run a build from console and them add to the server in eclipse, it will work.

Go to root of your project and run the maven command: mvn -PautoInstallPackage -PintegrationServer install

~kautuk

View solution in original post