Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Bundles going in installed state after service pack install

Avatar

Avatar
Ignite 1
Level 2
sjb99
Level 2

Likes

5 likes

Total Posts

6 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back 5
Give Back 3
Give Back
Boost 5
View profile

Avatar
Ignite 1
Level 2
sjb99
Level 2

Likes

5 likes

Total Posts

6 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back 5
Give Back 3
Give Back
Boost 5
View profile
sjb99
Level 2

10-04-2021

Hi,

I installed service pack 8 on a fresh AEM 6.5 instance in my mac machine. 37 bundles go into Install state which were previously active before service pack. I tried multiple times by setting up fresh instance again but its the same thing. What could be the solution?

Screen Shot 2021-04-10 at 11.48.37 PM.png

Replies

Avatar

Avatar
Establish
MVP
Ravi_Pampana
MVP

Likes

183 likes

Total Posts

234 posts

Correct Reply

70 solutions
Top badges earned
Establish
Contributor
Shape 1
Ignite 5
Ignite 3
View profile

Avatar
Establish
MVP
Ravi_Pampana
MVP

Likes

183 likes

Total Posts

234 posts

Correct Reply

70 solutions
Top badges earned
Establish
Contributor
Shape 1
Ignite 5
Ignite 3
View profile
Ravi_Pampana
MVP

10-04-2021

Hi,

 

Can you check by expanding the bundles and see whether there are any unresolved bundles which has version conflicts ? Also, check whether the uber jar was updated to the correct AEM version. 

Avatar

Avatar
Ignite 1
Level 2
sjb99
Level 2

Likes

5 likes

Total Posts

6 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back 5
Give Back 3
Give Back
Boost 5
View profile

Avatar
Ignite 1
Level 2
sjb99
Level 2

Likes

5 likes

Total Posts

6 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back 5
Give Back 3
Give Back
Boost 5
View profile
sjb99
Level 2

10-04-2021

Thanks for responding. Where do I correct the uber jar? Because I'm not installing my project. It's just the service pack which I installed. In few bundles there is some version mismatch and is highlighted in red. But what do I do to resolve it? It's a complete fresh installation and only Adobe given package is installed. Same thing happening with SP7 too

Avatar

Avatar
Ignite 1
Level 2
sjb99
Level 2

Likes

5 likes

Total Posts

6 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back 5
Give Back 3
Give Back
Boost 5
View profile

Avatar
Ignite 1
Level 2
sjb99
Level 2

Likes

5 likes

Total Posts

6 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back 5
Give Back 3
Give Back
Boost 5
View profile
sjb99
Level 2

10-04-2021

@Ravi_Pampana Thanks for responding. Where do I correct the uber jar? Because I'm not installing my project. It's just the service pack which I installed. In few bundles there is some version mismatch and is highlighted in red. But why is showing such error? It's a complete fresh installation and only Adobe given package is installed. Same thing happening with SP7 tooScreen Shot 2021-04-10 at 11.57.34 PM.pngScreen Shot 2021-04-11 at 12.00.03 AM.png

Avatar

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,081 likes

Total Posts

3,121 posts

Correct Reply

1,061 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,081 likes

Total Posts

3,121 posts

Correct Reply

1,061 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile
Jörg_Hoh
Employee

11-04-2021

Have you restarted the instance? IIRC that's what Adobe mandates.

Avatar

Avatar
Ignite 1
Level 2
sjb99
Level 2

Likes

5 likes

Total Posts

6 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back 5
Give Back 3
Give Back
Boost 5
View profile

Avatar
Ignite 1
Level 2
sjb99
Level 2

Likes

5 likes

Total Posts

6 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back 5
Give Back 3
Give Back
Boost 5
View profile
sjb99
Level 2

11-04-2021

Hi @Jörg_Hoh , yes I restarted it multiple times. even tried setting up fresh instance again and restarted it multiple times but same issue after install SP8 or even SP7 for that matter.

Avatar

Avatar
Establish
MVP
Ravi_Pampana
MVP

Likes

183 likes

Total Posts

234 posts

Correct Reply

70 solutions
Top badges earned
Establish
Contributor
Shape 1
Ignite 5
Ignite 3
View profile

Avatar
Establish
MVP
Ravi_Pampana
MVP

Likes

183 likes

Total Posts

234 posts

Correct Reply

70 solutions
Top badges earned
Establish
Contributor
Shape 1
Ignite 5
Ignite 3
View profile
Ravi_Pampana
MVP

11-04-2021

What is the version of Java you are having and did you see any errors in the log files (error.log) ? What is the process you are following to upgrade ? Is it installing Service pack 8 on plan version of AEM 6.5 ?

Avatar

Avatar
Ignite 1
Level 2
sjb99
Level 2

Likes

5 likes

Total Posts

6 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back 5
Give Back 3
Give Back
Boost 5
View profile

Avatar
Ignite 1
Level 2
sjb99
Level 2

Likes

5 likes

Total Posts

6 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back 5
Give Back 3
Give Back
Boost 5
View profile
sjb99
Level 2

12-04-2021

@Ravi_Pampana @Jörg_Hoh Hi, thank you for the responses. I'm using JDK 11.0.10 which I downloaded from Adobe. This is a fresh installation where I'm installing on plain AEM 6.5 instance. Literally opening the cq jar for the first time, once its up and all bundles are fine, I restart it and I install SP8 and restart it again after the package is installed after 45 mins or so. I even started waiting that long for better results but the behavior is same. Could this be due to my Mac version? I'm using Mac 10.12.6 (Sierra). Please find the error log. So many unsresolved bundles due to some mismatch. This is a fresh installation, so I don't understand how mismatch can come up. Please help.

13.04.2021 01:40:38.405 *ERROR* [FelixDispatchQueue] com.day.cq.mcm.cq-mcm-emailprovider FrameworkEvent ERROR (org.osgi.framework.BundleException: Unable to resolve com.day.cq.mcm.cq-mcm-emailprovider [364](R 364.0): missing requirement [com.day.cq.mcm.cq-mcm-emailprovider [364](R 364.0)] osgi.wiring.package; (osgi.wiring.package=com.day.cq.wcm.foundation.forms) [caused by: Unable to resolve com.day.cq.wcm.cq-wcm-foundation [468](R 468.1): missing requirement [com.day.cq.wcm.cq-wcm-foundation [468](R 468.1)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.cq.wcm.ui.components.container.service)(version>=1.0.0)(!(version>=2.0.0)))] Unresolved requirements: [[com.day.cq.mcm.cq-mcm-emailprovider [364](R 364.0)] osgi.wiring.package; (osgi.wiring.package=com.day.cq.wcm.foundation.forms)])
org.osgi.framework.BundleException: Unable to resolve com.day.cq.mcm.cq-mcm-emailprovider [364](R 364.0): missing requirement [com.day.cq.mcm.cq-mcm-emailprovider [364](R 364.0)] osgi.wiring.package; (osgi.wiring.package=com.day.cq.wcm.foundation.forms) [caused by: Unable to resolve com.day.cq.wcm.cq-wcm-foundation [468](R 468.1): missing requirement [com.day.cq.wcm.cq-wcm-foundation [468](R 468.1)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.cq.wcm.ui.components.container.service)(version>=1.0.0)(!(version>=2.0.0)))] Unresolved requirements: [[com.day.cq.mcm.cq-mcm-emailprovider [364](R 364.0)] osgi.wiring.package; (osgi.wiring.package=com.day.cq.wcm.foundation.forms)]
	at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
	at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
	at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
	at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
	at java.base/java.lang.Thread.run(Thread.java:834)

Screen Shot 2021-04-13 at 1.43.15 AM.png

Avatar

Avatar
Ignite 1
Level 2
sjb99
Level 2

Likes

5 likes

Total Posts

6 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back 5
Give Back 3
Give Back
Boost 5
View profile

Avatar
Ignite 1
Level 2
sjb99
Level 2

Likes

5 likes

Total Posts

6 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back 5
Give Back 3
Give Back
Boost 5
View profile
sjb99
Level 2

14-04-2021

hi @Jörg_Hoh @kautuk_sahni any help or pointers regarding this please? Tried everything with different java versions also

Avatar

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,081 likes

Total Posts

3,121 posts

Correct Reply

1,061 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,081 likes

Total Posts

3,121 posts

Correct Reply

1,061 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile
Jörg_Hoh
Employee

15-04-2021

Can you try to start bundles manually and see if that unblocks this situation? IIRC I had this behaviour sometimes (and it's definitely not planned to behave like this).