Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Bundle is in installed state while doing AEM 6.5 upgrade from 6.3

srikanthg212933
Level 3
Level 3

we are trying to upgrade from 6.3 to 6.5. changed uber jar version to 6.5.2 and deployed the jar file in new AEM 6.5 version but bundle is installed state with the below error.

org.apache.felix.http.jetty %bundles.pluginTitle: Cannot start (org.osgi.framework.BundleException: Unable to resolve wnt-core [613](R 613.0): missing requirement [wnt-core [613](R 613.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.distribution)(version>=0.3.0)(!(version>=1.0.0))) Unresolved requirements: [[wnt-core [613](R 613.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.distribution)(version>=0.3.0)(!(version>=1.0.0)))])

org.osgi.framework.BundleException: Unable to resolve wnt-core [613](R 613.0): missing requirement [wnt-core [613](R 613.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.distribution)(version>=0.3.0)(!(version>=1.0.0))) Unresolved requirements: [[wnt-core [613](R 613.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.distribution)(version>=0.3.0)(!(version>=1.0.0)))]

I have understood that org.apache.sling.distribution dependecy version should be greater than 0.3.0 and less than 1.0.0 . So I have tried adding below dependency but the issue still persists. Please do let me know if I am missing something here. Any leads will be appreciated.

<dependency>

<artifactId>org.apache.sling.distribution.api</artifactId>

<version>0.3.0</version>

<groupId>org.apache.sling</groupId>

<scope>provided</scope>

</dependency>

1 Accepted Solution
aemmarc
Correct answer by
Employee
Employee

There were a ton of deprecations in the 6.5 uber jar.  I suggest trying out this build : https://repo.adobe.com/nexus/content/repositories/releases/com/adobe/aem/uber-jar/6.5.0.0/uber-jar-6...

View solution in original post

0 Replies
jbrar
Employee
Employee

Can you confirm the AEM version is 6.5.2 ? Ideally, you should be using the same version of uber jar as the AEM version.

srikanthg212933
Level 3
Level 3

yes I have 6.5.2 service pack installed.

aemmarc
Correct answer by
Employee
Employee

There were a ton of deprecations in the 6.5 uber jar.  I suggest trying out this build : https://repo.adobe.com/nexus/content/repositories/releases/com/adobe/aem/uber-jar/6.5.0.0/uber-jar-6...

View solution in original post

srikanthg212933
Level 3
Level 3

I have tried with uber jar deprecated apis but it didn't work. unfortunately issue still persists.

jbrar
Employee
Employee

Can you log a daycare ticket and we can further investigate whats causing the issue?