Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Assets Link Share - Video Playback Issues

Avatar

Level 2

When a video is shared via the "Link Share" feature the video fails to load in chrome. If the whitespace is clicked the video loads and plays. In firefox the video preview does load. However, intermittently the play button does not load.

Screen Shot 2019-01-31 at 10.20.32 AM.png

Is this expected behavior?

1 Accepted Solution

Avatar

Correct answer by
Level 2

Screen Shot 2019-02-01 at 10.08.21 AM.png

This was the culprit.

View solution in original post

0 Replies

Avatar

Community Advisor

Check the console logs/network tab for any errors/warning?

works fine in chrome:

1680677_pastedImage_1.png

Avatar

Level 2

Thank you very much for the reply.

I'm curious now, can you test this the link in a non-aem-authenticated tab/window (i.e. incognito tab)? I've found that there is javascript that is not accessible if you are not authenticated to aem. This use case would be for an external user.

Avatar

Community Advisor

If it works for you in FF but not in Chrome, then it could be an issue with your Chrome extensions/plugins. Check if you are able to access the thumbnail image in Chrome?

It would be something like /libs/dam/gui/content/assets/assetlinkshare.html/content/dam/eaem-decrypt-assets-filter-6420.mp4.thumb.319.319.png?ch_ck=1548415046000&sh=b9e262cf_5215_422a_bb50_fef385e5b2f3.ejJ58PdI4mMDpABpddLa7nJwf2Zk1Bf5rBWWXudgTXY&path=

If the 'javascript' is not accessible to un-authenticated users then grant read access to 'anonymous' user for that path via /useradmin or otherwise share the equivalent publish-server link.

a.gif

Avatar

Level 2

The errors I am getting in chrome web console are actually:

test2.mp4:1 Refused to execute script from 'https://localhost:4502/libs/granite/core/content/login.html?resource=%2Flibs%2Fdam%2Fcomponents%2Fsc...' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.

test2.mp4:1 Refused to execute script from 'https://localhost:4502/libs/granite/core/content/login.html?resource=%2Flibs%2Fcq%2Fgui%2Fcomponents...' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.

test2.mp4:1 Refused to execute script from 'https://localhost:4502/libs/granite/core/content/login.html?resource=%2Flibs%2Fcq%2Fgui%2Fcomponents...' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.

test2.mp4:1 Refused to execute script from 'https://localhost:4502/libs/granite/core/content/login.html?resource=%2Flibs%2Fcq%2Fgui%2Fcomponents...' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.

I thought the solution would be permissions. This does not appear to be the case.

Avatar

Community Advisor

Why does it throw you to login.html. The embedded token should allow access without logging-in.

check the url in my case above it has --- sh=b9e262cf_5215_422a_bb50_fef385e5b2f3.ejJ58PdI4mMDpABpddLa7nJwf2Zk1Bf5rBWWXudgTXY

Avatar

Level 2

I am not sure actually. I can confirm that while logged in everything loads properly. It's only when a user outside of AEM logs in that this situation occurs.

Avatar

Correct answer by
Level 2

Screen Shot 2019-02-01 at 10.08.21 AM.png

This was the culprit.