Expand my Community achievements bar.

Radically easy to access on brand approved content for distribution and omnichannel performant delivery. AEM Assets Content Hub and Dynamic Media with OpenAPI capabilities is now GA.
SOLVED

Asset offloading stuck

Avatar

Level 4

My client was given a development dynamic media sandbox so that their testing in a dev and UAT sandbox of the AEM would not change published presets in their production media server. I have the replication agents set up and they connect fine but when the step to perform the offloading runs, or not, the workflow stops there. There are only two steps to the workflow. First a gate keeper step then the step to perform the offloading. Both are standard AEM workflow steps with no custom script. In the history of the workflows and the logs, I see the workflow start, the gate keeper step complete, then nothing. I don't see any errors in the logs or anything concerning the offloading. Images set to be offloaded don't process and sit in limbo.

My question is how do I diagnose what the issue is so that a remedy can be found.

1 Accepted Solution

Avatar

Correct answer by
Level 10

Have you set your log levels to 'debug' ? Also it depends on the offload setup thats been done. There might not be any error aswell nothing to process  !! 

Can you give more details on how you have setup and whats has been targetted to do as part of offload workflow

View solution in original post

2 Replies

Avatar

Correct answer by
Level 10

Have you set your log levels to 'debug' ? Also it depends on the offload setup thats been done. There might not be any error aswell nothing to process  !! 

Can you give more details on how you have setup and whats has been targetted to do as part of offload workflow

Avatar

Level 4

bsloki wrote...

Have you set your log levels to 'debug' ? Also it depends on the offload setup thats been done. There might not be any error aswell nothing to process  !! 

Can you give more details on how you have setup and whats has been targetted to do as part of offload workflow

 

Yes the logs have been set to debug.

The workflow is out of the box Adobe stuff. It is the "DAM Update Asset Offloading" model. There hasn't been any customization to the step. If there is nothing to do, then why does it hang? Why wouldn't it just see that there is nothing to do and terminate normally?

I guess the big question is what exactly does it do and do I even need it activated?