Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Allowed Components no longer showing in layour container

Avatar

Level 2

Hello

Yesterday, I received some really helpful advice around components and whether they're shareable across more than one site. Today, I wanted to follow the steps I'd been shown yesterday, but the components within the layout container are no longer visible, and when selecting the layout container I no longer see the 'policies' button. I may have inadvertantly pressed/delted something, but I can't for the life of me work out what.

 

Any help will be apppreciated. ThanksPolicies and Components no longer showing.PNG

1 Accepted Solution

Avatar

Correct answer by
Level 10

hi @simirving ,
You are trying to check at the wrong place. Please follow the below steps:

1. On the page, click on the three lines shown in the image and click on edit template from the dropdown.

2. New tab will open, there select the parsys and click on the policy icon as shown in the image. 

3. When new page loads, select the components you need to allow and click ok.

4. Now go back to your page, refresh it and double click on layout container. You will see the list of allowed components.Screen Shot 2022-02-02 at 10.56.14 AM.pngScreen Shot 2022-02-02 at 10.57.21 AM.pngScreen Shot 2022-02-02 at 10.59.47 AM.pngScreen Shot 2022-02-02 at 11.01.08 AM.png

View solution in original post

6 Replies

Avatar

Correct answer by
Level 10

hi @simirving ,
You are trying to check at the wrong place. Please follow the below steps:

1. On the page, click on the three lines shown in the image and click on edit template from the dropdown.

2. New tab will open, there select the parsys and click on the policy icon as shown in the image. 

3. When new page loads, select the components you need to allow and click ok.

4. Now go back to your page, refresh it and double click on layout container. You will see the list of allowed components.Screen Shot 2022-02-02 at 10.56.14 AM.pngScreen Shot 2022-02-02 at 10.57.21 AM.pngScreen Shot 2022-02-02 at 10.59.47 AM.pngScreen Shot 2022-02-02 at 11.01.08 AM.png

Avatar

Level 2

Thanks for coming back to me on this @anish-s It is appreciated.
Step 1 in your instructions is straight forward. But at step 2 I come undone, because the 'Policy' icon no longer shows. After selecting 'edit template' from the 3 lines in the screen's top-left corner, then highlighting a layout container, this is what I see:

 

No Policy icon displayed.PNG

Avatar

Level 5

Please make sure u are selected edit mode on the top right (dropdown)

Avatar

Level 2

Hi @Manikumar thanks for coming back to me.

When clicking the 'Edit' option on the screen's top-right corner, I'm presented with these options:

Edit right hand drop down menu.PNG

I click on 'edit', scroll down to a layout container, where I'd expect to see default Components, but instead I'm presented with this:

 

simirving_0-1643971232577.png

Earlier in the week, where the '+' symbol currently sits, I was presented with 5 icons, one of which was 'Policies'. I'm now wondering where this has gone and if I can ever get it back? Clicking on '+' today brings up a menu of Components I used to see in the Layout Container, but I want to add to these Components, but now I can't.

 

The other steps I've tried are to click the three lines in the top-left of the page, and selecting 'edit template', I'm then presented with the following in the top-right corner, but there's no option to 'edit' in the top-right hand corner. 

 

Edit feature not in dropdown list.PNG

 

I feel like I'm going around in circles 🙂

Avatar

Level 5

Hi @simirving ,

I think you are combining two different things here.

We have two different dropdown options based on whether editing is done to page or template

If you are editing the page you can see below options

Manikumar_0-1643986265557.png

 

On this you cannot see the policies but you can see the + icon to add the components on the page.

If you are editing the template by clicking on pageproperties as below

Manikumar_1-1643986345641.png

 

You can different options where all the component related policies and allowed components are seen.

Manikumar_2-1643986400378.png

 

Once you are on the template editing click on the highlighted box and click on the policies icon and window with all the layout container policy with allowed components will be shown as below

Manikumar_3-1643986482170.png

 

Avatar

Level 2

Hello @Manikumar, thanks for your reply.

 

I've followed steps to edit a template you kindly shared last week; after selecting 'edit template' from:

AEM sliders.PNG

 

 

I'm still unable to view available components within layout container. 

 

In this video; https://youtu.be/CJrBr0a-jpI I noticed this url: 

/editor.html/conf/we-retail/settings/wcm/templates/hero-page/structure.html

 

When I enter the url above and hit enter, 'structure' changes to 'initial', see below url:

/editor.html/conf/we-retail/settings/wcm/templates/hero-page/initial.html

 

Could this be influencing what I'm able to edit? Thanks again.