Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM6.3 color picker plugin on RTE

Avatar

Level 3

Hi,

I am trying to reuse the color plugin described on this blog: Experiencing Adobe Experience Manager - Day CQ: AEM 63 - Touch UI RTE (Rich Text Editor) Color Picke...

The problem is that the component only appears when I put the node "experience-aem" on:

cq:editConfig/cq:inplaceEditing/config/rtePlugins

But it appears two times on inline edition and it does not work!

I know why it is appearing two times, though, that is because is reading from the demo plugin too.

But if I delete the demo plugin I have an error not found on archive /apps/eaem-touchui-dialog-rte-color-picker/color-picker-popover/cq:dialog.html

but on this path that was no file cq:dialog.html

I just want to use this in inplace editing maximized

I am not understanding this behavior

some help?

Thank you

1 Accepted Solution

Avatar

Correct answer by
Level 10

When you follow the instructions in this article - written by one of our TOuch UI Eng members - is it not working for you. I recall doing this article a few months ago and it worked.

View solution in original post

6 Replies

Avatar

Correct answer by
Level 10

When you follow the instructions in this article - written by one of our TOuch UI Eng members - is it not working for you. I recall doing this article a few months ago and it worked.

Avatar

Level 10

Here is the screenshot where i got it working...

RTECOLOR.png

Avatar

Level 2

Hi smacdonald,
I have implemented the RTE color picker with this aem 6.4 link --> http://experience-aem.blogspot.com/2018/05/aem-64-touch-ui-rte-rich-text-editor-color-picker-plugin.... After the upgrade from 6.4.2 to 6.4.8.2 SP, i am getting the below error message in the console while selecting the color picker

vivianseba_0-1601552985019.png
Could you please suggest with the fix ?

 

Avatar

Level 3

Hi! thank you for your reply!

For me is it working perfect on inplace editing maximized too. But my doubt is that when I put on cq:inplaceEditing node it is appearing on inline as well, but here does not work. I don't know how to make it appear only on maximized view. Or make it work on inline, whichever is easier

1415382_pastedImage_0.png

Thank you!

Avatar

Level 1

Hi for me this plugin is working but when i am escaping the dialog it's not closing and throwing some errors

ANy help?

Avatar

Level 1

I can not open the below page, would you send me the package via email? Thanks very much.

My email address is : wangjune1024@gmail.com