Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM upgrade 6.2 to 6.5 issue

vandanasharma
Level 2
Level 2

missing requirement [cc-services.core [584](R 584.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.commons.csv)(version>=1.6.0)(!(version>=2.0.0))) Unresolved requirements: [[cc-services.core [584](R 584.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.commons.csv)(version>=1.6.0)(!(version>=2.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:998)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:984)
at org.apache.sling.installer.core.impl.tasks.BundleStartTask.execute(BundleStartTask.java:97) [org.apache.sling.installer.core:3.9.0]
at org.apache.sling.installer.core.impl.OsgiInstallerImpl.doExecuteTasks(OsgiInstallerImpl.java:914) [org.apache.sling.installer.core:3.9.0]
at org.apache.sling.installer.core.impl.OsgiInstallerImpl.executeTasks(OsgiInstallerImpl.java:749) [org.apache.sling.installer.core:3.9.0]
at org.apache.sling.installer.core.impl.OsgiInstallerImpl.run(OsgiInstallerImpl.java:298) [org.apache.sling.installer.core:3.9.0]
at java.lang.Thread.run(Thread.java:745)

1 Accepted Solution
ArpitVarshney
Correct answer by
Community Advisor
Community Advisor

Hi @vandanasharma 

Please add the maven dependency for the org.apache.commons.csv in your pom files.[Reference: https://mvnrepository.com/artifact/org.apache.commons/commons-csv/1.8 ]

<dependency>
     <groupId>org.apache.commons</groupId>
    <artifactId>commons-csv</artifactId>
     <version>1.8</version>
</dependency>

 

After that, verify the <Embed-Dependency> tag of maven-bundle-plugin [You can either include all the dependencies or you can configure to not include specific ones]. The scope attribute lets you configure which dependency jars you want to include based on their include scope. You should not include the dependencies which are only needed for compile and for the test.

Below is the example to add the commons-csv to the embed dependency.

 

<plugin>
<groupId>org.apache.felix</groupId>
<artifactId>maven-bundle-plugin</artifactId>
<extensions>true</extensions>
<configuration>
<instructions>
<Embed-Dependency>*;
|commons-csv
</Embed-Dependency>
<Embed-Transitive>true</Embed-Transitive>
</instructions>
</configuration>
</plugin>

 

View solution in original post

2 Replies
ArpitVarshney
Correct answer by
Community Advisor
Community Advisor

Hi @vandanasharma 

Please add the maven dependency for the org.apache.commons.csv in your pom files.[Reference: https://mvnrepository.com/artifact/org.apache.commons/commons-csv/1.8 ]

<dependency>
     <groupId>org.apache.commons</groupId>
    <artifactId>commons-csv</artifactId>
     <version>1.8</version>
</dependency>

 

After that, verify the <Embed-Dependency> tag of maven-bundle-plugin [You can either include all the dependencies or you can configure to not include specific ones]. The scope attribute lets you configure which dependency jars you want to include based on their include scope. You should not include the dependencies which are only needed for compile and for the test.

Below is the example to add the commons-csv to the embed dependency.

 

<plugin>
<groupId>org.apache.felix</groupId>
<artifactId>maven-bundle-plugin</artifactId>
<extensions>true</extensions>
<configuration>
<instructions>
<Embed-Dependency>*;
|commons-csv
</Embed-Dependency>
<Embed-Transitive>true</Embed-Transitive>
</instructions>
</configuration>
</plugin>

 

View solution in original post

v1101
Level 5
Level 5
Vandana - Were you able to resolve the issue? I am also getting the similar error ? org.osgi.framework.BundleException: Unable to resolve com.*.framework-core [626](R 626.0): missing requirement [com..*.framework-core [626](R 626.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.jcr.resource)(version>=2.1.0)) Unresolved requirements: [[com..*.framework-core [626](R 626.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.jcr.resource)(version>=2.1.0))]