Expand my Community achievements bar.

AEM tools is not accessible

Avatar

Level 7

Hi,

Do any one has ever faced this issue. when i navigate to /miscadmin page in AEM it renders a blank page while server response is 200. All other pages load fine.

17 Replies

Avatar

Employee Advisor

- Check if you are getting any error in the log files when trying to load miscadmin

- Open the developer console in browser and check for any errors in the console OR any failing requests in the network tab

-  Try upping the json.maximumresults  of the Apache Sling Get Servlet

Avatar

Level 7

Network tab shows response 200 ok. I tried updating the Json.maximumresults = 100000 but with no luck.

Avatar

Level 7

the error.log shows below log

GET /miscadmin HTTP/1.1] libs.cq.workflow.components.collection.definition.resource.resource$jsp error while rendering resource:

java.lang.NullPointerException: null

        at org.apache.jsp.libs.cq.workflow.components.collection.definition.resource.resource_jsp._jspService(resource_jsp.java:165)

Avatar

Employee Advisor

Hello Prakash,

This error message suggests there might be something wrong with workflow packages.

I once saw the similar nullpointer exception in a case where workflow package had a resource(pages/assets) which was actually not present in the JCR.

Check if you have workflow packages in crxde.

Regards,

Vishu

Avatar

Community Advisor

Able to access http://localhost:4502/miscadmin  on Aem 6.5 .

Please check logs..

Avatar

Community Advisor

Hi

Please check Apache sling GET servlet configuration (system/console/configMgr), And verify if enable Json in checked.

Thanks

Dipti

Avatar

Employee Advisor

Did this happen after a SP installation ?

Avatar

Level 7

yes, it happens after we upgraded to 6.3.2.1. But it didn't started immediately after service pack installation

Avatar

Employee Advisor

Try with parameter /miscadmin?debugClientLibs=true

Avatar

Employee

Are you trying with admin user?

Avatar

Level 7

Thanks all for your opinion. i was able to fix it

Avatar

Employee Advisor

Can you share the root cause of the issue?

Avatar

Level 7

/libs/wcm/core/content/misc node get resolved to /miscadmin in aem and one of author has updated this node. That was the root cause of the issue. i reverted it back and it starts working.