Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM Instance not running error at starting quickstart on port 4502

rohankalra
Level 2
Level 2

I have aem6.5 and running AEM first time on my machine its not running getting hang at certain point. Tried running it through CMD using java -jar aem6.5-author-p4502.jar -Xmx1024m -XX:MaxPermSize=256m getting this error Verbose option not active, closing stdin and redirecting stdout and stder  I checked the logs at stdout and stder getting error 

*ERROR* [FelixStartLevel] ERROR: Bundle '1' Error starting slinginstall:C:\Users\Documents\AEM\aem\crx-quickstart\launchpad\startup\1\com.adobe.granite.crypto-3.4.16.jar (java.lang.ExceptionInInitializerError)
java.lang.ExceptionInInitializerError
at org.apache.felix.framework.URLHandlers.createURLStreamHandler(URLHandlers.java:513)
at java.base/java.net.URL.getURLStreamHandler(URL.java:1465)
at java.base/java.net.URL.<init>(URL.java:478)
at java.base/jdk.internal.loader.URLClassPath$JarLoader.<init>(URLClassPath.java:722)
at java.base/jdk.internal.loader.URLClassPath$3.run(URLClassPath.java:496)
at java.base/jdk.internal.loader.URLClassPath$3.run(URLClassPath.java:479)
at java.base/java.security.AccessController.doPrivileged(AccessController.java:691)
at java.base/jdk.internal.loader.URLClassPath.getLoader(URLClassPath.java:478)
at java.base/jdk.internal.loader.URLClassPath.getLoader(URLClassPath.java:447)
at java.base/jdk.internal.loader.URLClassPath.findResource(URLClassPath.java:293)
at java.base/java.net.URLClassLoader$2.run(URLClassLoader.java:616)
at java.base/java.net.URLClassLoader$2.run(URLClassLoader.java:614)
at java.base/java.security.AccessController.doPrivileged(AccessController.java:391)
at java.base/java.net.URLClassLoader.findResource(URLClassLoader.java:613)
at com.adobe.granite.crypto.internal.InternalClassLoaderWrapper$JarFileClassLoader.findClass(InternalClassLoaderWrapper.java:175)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:586)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:519)
at com.adobe.granite.crypto.internal.Activator.getOrCreateKeyGenerator(Activator.java:145)
at com.adobe.granite.crypto.internal.Activator.start(Activator.java:65)
at org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:698)
at org.apache.felix.framework.Felix.activateBundle(Felix.java:2402)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2308)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.base/java.lang.Thread.run(Thread.java:831)
Caused by: java.lang.RuntimeException: Unable to make protected boolean java.net.URLStreamHandler.equals(java.net.URL,java.net.URL) accessible: module java.base does not "opens java.net" to unnamed module @660acfb
at org.apache.felix.framework.URLHandlersStreamHandlerProxy.<clinit>(URLHandlersStreamHandlerProxy.java:104)
... 25 more
Caused by: java.lang.reflect.InaccessibleObjectException: Unable to make protected boolean java.net.URLStreamHandler.equals(java.net.URL,java.net.URL) accessible: module java.base does not "opens java.net" to unnamed module @660acfb
at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:357)
at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:297)
at java.base/java.lang.reflect.Method.checkCanSetAccessible(Method.java:199)
at java.base/java.lang.reflect.Method.setAccessible(Method.java:193)
at org.apache.felix.framework.util.SecureAction.setAccesssible(SecureAction.java:871)
at org.apache.felix.framework.URLHandlersStreamHandlerProxy.<clinit>(URLHandlersStreamHandlerProxy.java:79)
... 25 more
18.09.2021 19:19:59.413 *ERROR* [FelixStartLevel] ERROR: Bundle '21' EventDispatcher: Error during dispatch. (java.lang.NoClassDefFoundError: Could not initialize class org.apache.felix.framework.URLHandlersStreamHandlerProxy)
java.lang.NoClassDefFoundError: Could not initialize class org.apache.felix.framework.URLHandlersStreamHandlerProxy
at org.apache.felix.framework.URLHandlers.createURLStreamHandler(URLHandlers.java:513)
at java.base/java.net.URL.getURLStreamHandler(URL.java:1465)
at java.base/java.net.URL.<init>(URL.java:678)
at java.base/java.net.URL.fromURI(URL.java:746)
at java.base/java.net.URI.toURL(URI.java:1139)
at org.apache.sling.installer.core.impl.InternalResource.create(InternalResource.java:87)
at org.apache.sling.installer.core.impl.OsgiInstallerImpl.createResources(OsgiInstallerImpl.java:384)
at org.apache.sling.installer.core.impl.OsgiInstallerImpl.registerResources(OsgiInstallerImpl.java:477)
at org.apache.sling.launchpad.installer.impl.LaunchpadConfigInstaller.install(LaunchpadConfigInstaller.java:207)
at org.apache.sling.launchpad.installer.impl.LaunchpadConfigInstaller.install(LaunchpadConfigInstaller.java:150)
at org.apache.sling.launchpad.installer.impl.ServicesListener.notifyChange(ServicesListener.java:100)
at org.apache.sling.launchpad.installer.impl.ServicesListener$Listener.retainService(ServicesListener.java:182)
at org.apache.sling.launchpad.installer.impl.ServicesListener$Listener.serviceChanged(ServicesListener.java:205)
at org.apache.felix.framework.EventDispatcher.invokeServiceListenerCallback(EventDispatcher.java:990)
at org.apache.felix.framework.EventDispatcher.fireEventImmediately(EventDispatcher.java:838)
at org.apache.felix.framework.EventDispatcher.fireServiceEvent(EventDispatcher.java:545)
at org.apache.felix.framework.Felix.fireServiceEvent(Felix.java:4833)
at org.apache.felix.framework.Felix.registerService(Felix.java:3804)
at org.apache.felix.framework.BundleContextImpl.registerService(BundleContextImpl.java:328)
at org.apache.sling.settings.impl.ServicesListener.<init>(ServicesListener.java:64)
at org.apache.sling.settings.impl.Activator.start(Activator.java:38)
at org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:698)
at org.apache.felix.framework.Felix.activateBundle(Felix.java:2402)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2308)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.base/java.lang.Thread.run(Thread.java:831)

 

Kindly help It doesn't happened before I have checked my file version also downloaded new Jar file and checked Java and JDK version both are fine it should run once I click on JAR.

1 Accepted Solution
Asutosh_Jena_
Correct answer by
Community Advisor
Community Advisor

@rohankalra 

AEM does not support JDK version beyond 11. So you need to downgrade your JDK version to either 8 or 11. I will suggest to downgrade to 11 and then proceed with installation. It will resolve your issue 🙂

 

You can see the technical requirement for AEM here:

https://experienceleague.adobe.com/docs/experience-manager-65/deploying/introduction/technical-requi...

 

 

Thanks!

View solution in original post

2 Replies
Asutosh_Jena_
Community Advisor
Community Advisor

Hi @rohankalra 

 

Bundle 21 which is com.adobe.granite.crypto is not active. Can you navigate to system/console/bundle and try to activate is manually?

 

Ideally it should be activated while startup of the instance.

 

Thanks!

rohankalra
Level 2
Level 2

The instance is not running there is no way I can access the Bundles.

Asutosh_Jena_
Community Advisor
Community Advisor

If you are unable to start the instance, then you need to start with a fresh installation with AEM 6.5.0.0 and once it's started proceed with the service pack upgrade.

 

Thanks!

rohankalra
Level 2
Level 2

I have downloaded that file 4-5 times thinking like that but same thing happening meanwhile I tried running in cmd I am getting same thing

Verbose option not active, closing stdin and redirecting stdout and stderr
Redirecting stdout to C:\Users\Documents\AEM\aem\crx-quickstart\logs\stdout.log
Redirecting stderr to C:\Users\Documents\AEM\aem\crx-quickstart\logs\stderr.log

and in those files error I have already Posted

Asutosh_Jena_
Community Advisor
Community Advisor

What's the RAM size of your system and which version of JDK are you running with?

 

Can you please start a fresh instance by running the below command in the directory where the JAR file with name "aem-author-p4502.jar" is present.

 

java -jar aem-author-p4502.jar 

 

Once the instance is up and running check if all the bundles are active before installing any service pack.

 

Thanks!

rohankalra
Level 2
Level 2

ok My Ram Size is 16GB and I have Java 16.0.2 the current specification is 

java version "16.0.2" 2021-07-20
Java(TM) SE Runtime Environment (build 16.0.2+7-67)
Java HotSpot(TM) 64-Bit Server VM (build 16.0.2+7-67, mixed mode, sharing)

Asutosh_Jena_
Correct answer by
Community Advisor
Community Advisor

@rohankalra 

AEM does not support JDK version beyond 11. So you need to downgrade your JDK version to either 8 or 11. I will suggest to downgrade to 11 and then proceed with installation. It will resolve your issue 🙂

 

You can see the technical requirement for AEM here:

https://experienceleague.adobe.com/docs/experience-manager-65/deploying/introduction/technical-requi...

 

 

Thanks!

rohankalra
Level 2
Level 2

**bleep** You are right man You saved my hours thanks  a lot man.

ArunaSurukunta
Level 5
Level 5

Please check below things first before you get start with installation of AEM.

 

1. Java 11 or Java 1.8 version

2. Minimum of 4 gb space

Set correct path variables for Java in environment variables and then try running command to check Java -v

 

yoy can double click the jar file if you're using windows or run the command by navigating to the jar file location 

Java - jar <jar file name>

you have to monitor the console log to understand what is going on. Give 10 to 15 mins of time to install AEM and then validate AEM by accessing http://localhost:4502/