Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

AEM Inline Editor adds "span" tag to text with inline styles when removing a line break

Avatar

Level 1

When editing a text component using the inline rich text editor, if I delete a line break (merged 2 paragraphs into one) and then save and close the inline rich text editor, the next time I open that same text component and view its source(in the config editor), a 'span' tag gets added around the paragraph with a lot of unnecessary stylings which I don't want.
@rte @AEM 

4 Replies

Avatar

Employee Advisor

@amohite hi,

 

I tried performing the same steps on RTE locally. For me it is working fine when I merged the two paras, there are no extra spans added at all. 

 

I am using AEM 6.5.5

resourceType :: cq/gui/components/authoring/dialog/richtext

Can you check you dont have any custom code changing the data before saving ?

Thanks,

Milind 

Avatar

Community Advisor

Hi @amohite 

 

A couple of quick questions:

  • What's your AEM version
  • What's your core component version
  • Are you seeing any errors in the console?
  • Are you seeing any issues in the logs?
  • Can you check how the data is saved in the JCR once the component is saved?
  • Can you check if there is any custom code written for your RTE?

Thanks,

Kiran Vedantam.

Avatar

Community Advisor

I have tested on AEM 6.5.12 and We.retail Text component but no span tag has been added.

 

Please share .content.xml of your text component.