Expand my Community achievements bar.

July 31st AEM Gems Webinar: Elevate your AEM development to master the integration of private GitHub repositories within AEM Cloud Manager.

AEM Content Fragment (No items were found)

Avatar

Level 3

Dears

 

As shown in the figure below, the contentfragment list of all projects cannot be displayed, and the list of individual projects can only be displayed by direct access through the url. Does anyone know the reason?

 

_2-1658224327130.png

 

_1-1658223903699.png

 

7 Replies

Avatar

Community Advisor

@ChaoXiong Can you please let us know, which version of AEM you are using. Also, can you check if you are observing any console log or error in the error.log file?

Avatar

Level 3

Version 6.5.3 and Did not see any related error log

 

 

Avatar

Employee Advisor

@ChaoXiong hi,

 

Looks like permission issue to me.
Are you logged in as admin ? If not can you try to login as admin and check if you face the same issue ?

Hope that helps, thanks.

Avatar

Level 3

Yes, this is the local environment, I have always logged in directly as administrator

 

ChaoXiong_0-1658285031294.pngChaoXiong_1-1658285077094.png

 

Avatar

Level 3

1: Try to install AEM 6.5 in other folder. Install the necessary service package(6.5.3). Login as admin. Check the Content Fragment models. You should be able to see the folders.

2: Install all your project related packages. Now, again check the content fragment models folder. If you are not able to see the folders, then there might be custom oak index, which is used in your project. This might be the issue.

Avatar

Level 3

Thanks a lot, as you said
1. My recreated AEM can see those folders
2. Since I'm not sure what's affecting it, I just tried to package the conf and oak:index folders to install into the new AEM, and it worked without any issues, still able to see those folders.

ChaoXiong_1-1658289313694.png

 

ChaoXiong_0-1658289290132.png

 

Avatar

Level 3

There might be 2 issues.

1: Permission : Check are you logging using admin details? If not, check your group permission.

2: Custom Index : If your project has any custom oak index, then there might be case that, you cannot view any folder under configuration browser. I have faced the same issue in my previous project.