AEM Cloud SDK with CIF not coming up

Avatar

Avatar
Affirm 100
MVP
shelly-goel
MVP

Likes

246 likes

Total Posts

409 posts

Correct reply

105 solutions
Top badges earned
Affirm 100
Give Back 25
Ignite 3
Give Back 10
Validate 1
View profile

Avatar
Affirm 100
MVP
shelly-goel
MVP

Likes

246 likes

Total Posts

409 posts

Correct reply

105 solutions
Top badges earned
Affirm 100
Give Back 25
Ignite 3
Give Back 10
Validate 1
View profile
shelly-goel
MVP

12-06-2021

I have setup local AEM cloud SDK with CIF addon and installed Venia content package. I stopped the instance and tried to start it after few days but it does not come up. I see below errors in logs. Has anyone else faced the same issue?

 

*ERROR* [FelixLogListener] org.apache.sling.graphql.core.servlet.GraphQLServlet bundle org.apache.sling.graphql.core:0.0.9.T20210125100520-805f473 (511)[org.apache.sling.graphql.core.servlet.GraphQLServlet(2898)] : The activate method has thrown an exception (java.lang.IllegalArgumentException: A metric named org.apache.sling.graphql.core.servlet.GraphQLServlet.rt:graphql/sites/components/endpoint.m:GET_POST.e:json.cache_hit_rate already exists)
java.lang.IllegalArgumentException: A metric named org.apache.sling.graphql.core.servlet.GraphQLServlet.rt:graphql/sites/components/endpoint.m:GET_POST.e:json.cache_hit_rate already exists
at com.codahale.metrics.MetricRegistry.register(MetricRegistry.java:91) [io.dropwizard.metrics.core:3.2.4]
at org.apache.sling.graphql.core.servlet.GraphQLServlet.activate(GraphQLServlet.java:199)


*ERROR* [FelixLogListener] org.apache.sling.servlets.resolver FrameworkEvent ERROR (org.apache.felix.log.LogException: org.osgi.framework.ServiceException: Service factory returned null. (Component: org.apache.sling.graphql.core.GraphQLServlet (2898)))
org.apache.felix.log.LogException: org.osgi.framework.ServiceException: Service factory returned null. (Component: org.apache.sling.graphql.core.GraphQLServlet (2898))
at org.apache.felix.framework.ServiceRegistrationImpl.getFactoryUnchecked(ServiceRegistrationImpl.java:385)

*ERROR* [OsgiInstallerImpl] org.apache.jackrabbit.vault.packaging.registry.impl.JcrPackageRegistry Stream is not a content package. Missing 'jcr_root'.
13.06.2021 11:28:55.907 *INFO* [OsgiInstallerImpl] com.adobe.granite.installer.factory.packages.impl.PackageTransformer Unable to check content package {}
java.io.IOException: Stream is not a content package. Missing 'jcr_root'.
at org.apache.jackrabbit.vault.packaging.registry.impl.JcrPackageRegistry.upload(JcrPackageRegistry.java:377) [org.apache.jackrabbit.vault:3.4.0]
at org.apache.jackrabbit.vault.packaging.impl.JcrPackageManagerImpl.upload(JcrPackageManagerImpl.java:183) [org.apache.jackrabbit.vault:3.4.0]
at com.adobe.granite.installer.factory.packages.impl.PackageTransformer.checkForPackage(PackageTransformer.java:183) [com.adobe.granite.installer.factory.packages:1.0.18]
at com.adobe.granite.installer.factory.packages.impl.PackageTransformer.transform(PackageTransformer.java:132) [com.adobe.granite.installer.factory.packages:1.0.18]
at org.apache.sling.installer.core.impl.OsgiInstallerImpl.transformResources(OsgiInstallerImpl.java:974) [org.apache.sling.installer.core:3.11.4]
at org.apache.sling.installer.core.impl.OsgiInstallerImpl.run(OsgiInstallerImpl.java:298) [org.apache.sling.installer.core:3.11.4]
at java.base/java.lang.Thread.run(Thread.java:834)

Replies

Avatar

Avatar
Boost 500
MVP
Vijayalakshmi_S
MVP

Likes

566 likes

Total Posts

712 posts

Correct reply

236 solutions
Top badges earned
Boost 500
Give Back 50
Give Back 5
Ignite 10
Ignite 5
View profile

Avatar
Boost 500
MVP
Vijayalakshmi_S
MVP

Likes

566 likes

Total Posts

712 posts

Correct reply

236 solutions
Top badges earned
Boost 500
Give Back 50
Give Back 5
Ignite 10
Ignite 5
View profile
Vijayalakshmi_S
MVP

15-06-2021

Hi @shelly-goel,

Could you please let know if you were able to access system/console. If yes, can you try to restart the framework in your local instance via http://localhost:4502/system/console/vmstat

 

Avatar

Avatar
Affirm 100
MVP
shelly-goel
MVP

Likes

246 likes

Total Posts

409 posts

Correct reply

105 solutions
Top badges earned
Affirm 100
Give Back 25
Ignite 3
Give Back 10
Validate 1
View profile

Avatar
Affirm 100
MVP
shelly-goel
MVP

Likes

246 likes

Total Posts

409 posts

Correct reply

105 solutions
Top badges earned
Affirm 100
Give Back 25
Ignite 3
Give Back 10
Validate 1
View profile
shelly-goel
MVP

15-06-2021

No even the system console was not coming up

Avatar

Avatar
Boost 500
MVP
Vijayalakshmi_S
MVP

Likes

566 likes

Total Posts

712 posts

Correct reply

236 solutions
Top badges earned
Boost 500
Give Back 50
Give Back 5
Ignite 10
Ignite 5
View profile

Avatar
Boost 500
MVP
Vijayalakshmi_S
MVP

Likes

566 likes

Total Posts

712 posts

Correct reply

236 solutions
Top badges earned
Boost 500
Give Back 50
Give Back 5
Ignite 10
Ignite 5
View profile
Vijayalakshmi_S
MVP

21-06-2021

@shelly-goel,

Can you confirm if the instance is only with CIF add on and Venia package when it was last working or were there any changes done on top. 

If yes, please share high level details

 

Avatar

Avatar
Affirm 100
MVP
shelly-goel
MVP

Likes

246 likes

Total Posts

409 posts

Correct reply

105 solutions
Top badges earned
Affirm 100
Give Back 25
Ignite 3
Give Back 10
Validate 1
View profile

Avatar
Affirm 100
MVP
shelly-goel
MVP

Likes

246 likes

Total Posts

409 posts

Correct reply

105 solutions
Top badges earned
Affirm 100
Give Back 25
Ignite 3
Give Back 10
Validate 1
View profile
shelly-goel
MVP

21-06-2021

Yes it was just the CIF and venia package.

Avatar

Avatar
Boost 500
MVP
Vijayalakshmi_S
MVP

Likes

566 likes

Total Posts

712 posts

Correct reply

236 solutions
Top badges earned
Boost 500
Give Back 50
Give Back 5
Ignite 10
Ignite 5
View profile

Avatar
Boost 500
MVP
Vijayalakshmi_S
MVP

Likes

566 likes

Total Posts

712 posts

Correct reply

236 solutions
Top badges earned
Boost 500
Give Back 50
Give Back 5
Ignite 10
Ignite 5
View profile
Vijayalakshmi_S
MVP

22-06-2021

@shelly-goel,

Per the issue statement, GraphQLServlet(from GraphQL core bundle) has issue in Activate method which results in Service Registration issue.

Also, just realized the below issue on missing jcr_root

*ERROR* [OsgiInstallerImpl] org.apache.jackrabbit.vault.packaging.registry.impl.JcrPackageRegistry Stream is not a content package. Missing 'jcr_root'.

If you are able to recollect which package might have been installed by the timestamp - 13.06.2021 11:28:55.907, we can arrive at the problematic package. 

 

If not, given that it is local instance, I suggest to set up fresh following this article. (In the same sequence as mentioned in Local Set up section)

https://experienceleague.adobe.com/docs/experience-manager-cloud-service/content-and-commerce/storef...

Explicit note based on the article :

  • Cross check if you have Java 11
  • Latest CIF add on Sling Feature archive (.far) as that of Cloud service SDK version 
  • Before installing any new AEM archetype commerce project (includeCommerce=y) or Venia Store front packages, cross check if all the bundles(in particular GraphQL core/GraphQL related bundles) are active and configurations/bundles related to GraphQL are available via OSGI Installer. - http://localhost:4502/system/console/osgi-installer + no errors in error.log file. 

Avatar

Avatar
Affirm 100
MVP
shelly-goel
MVP

Likes

246 likes

Total Posts

409 posts

Correct reply

105 solutions
Top badges earned
Affirm 100
Give Back 25
Ignite 3
Give Back 10
Validate 1
View profile

Avatar
Affirm 100
MVP
shelly-goel
MVP

Likes

246 likes

Total Posts

409 posts

Correct reply

105 solutions
Top badges earned
Affirm 100
Give Back 25
Ignite 3
Give Back 10
Validate 1
View profile
shelly-goel
MVP

26-06-2021

@Vijayalakshmi_S 

I did not install any package other than venia and it all worked fine till I was using this instance. I just shut down this instance and started it few days later that it did not work.