Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM 6.5 Publisher startup issue

kirankumark9814
Level 2
Level 2

we are trying to upgrade from 6.3 to 6.5, We have taken fresh AEM 6.5 and deploying code and content from AEM 6.3 instance. After content migration, all AEM service hangs and stays in the startup in progress and most of the bundle shows resolved status

  1. happening only on the publisher mode of the instance 
  2. No significant error logs observed

 

1 Accepted Solution
kirankumark9814
Correct answer by
Level 2
Level 2

RESOLVED:  The issue was with 2 wrong DNS on Health check nodes. in AEM 6.5.5 this has been addressed added timeout configuration on this.

 

com.adobe.cq.security.hc.dispatcher.impl.DispatcherAccessHealthCheck
com.adobe.cq.security.hc.webserver.impl.ClickjackingHealthCheck

View solution in original post

8 Replies
Vaibhavi
Community Advisor
Community Advisor

Hi @kirankumark9814 , 

 

Have you checked stderr.log ? 

This will have the information about the errors during startup. 

kirankumark9814
Level 2
Level 2
Hi @Vaibhavi, I checked, No stderr.log coming. Is there any settings to need enable it ?
Varun_Shakya
Community Advisor
Community Advisor

After AEM 6.4 there is a change in repository and if you upgrading it to 6.5. I would suggest follow the guidelines provided by Adobe. 

https://docs.adobe.com/content/help/en/experience-manager-65/deploying/upgrading/upgrade.html

 

surabhikatiyar
Employee
Employee

From the description, I understand that the issue is only coming in the Publisher and the Author has been upgraded successfully with any such issue.

 

So, in this case, check the upgrade logs if the upgrade has been done successfully without any errors. Then check the stderr.log file for errors during the startup of the AEM Publish instance.

kirankumark9814
Level 2
Level 2
It is not correct answer, just clicked by mistakenly. There are no stderr.log coming on the instance and we are not doing in-place upgrade here.
surabhikatiyar
Employee
Employee

kirankumark9814 Try to create a new publisher again and check if the same issue comes up and if yes then open a support ticket so that this can be investigated in detail.

kirankumark9814
Level 2
Level 2

@surabhikatiyarTried recreating multiple times and observed the same issue, also observed service will come up after 2 or 3 Hrs and again hangs in case if we restart. Too weird

 

 

During startup, I Can see this error

*ERROR* [FelixStartLevel] com.adobe.cq.deserfw.impl.DeserializationFirewallImpl Unable to load Attach API. Unable to dynamically load deserialization protection agent. This usually happens when running a JRE (instead of a JDK) or a JVM that doesn't provide the Attach API. Please review the AEM Java Deserialization Firewall documentation for how to load the deserialization agent via JVM command-line arguments.

kirankumark9814
Correct answer by
Level 2
Level 2

RESOLVED:  The issue was with 2 wrong DNS on Health check nodes. in AEM 6.5.5 this has been addressed added timeout configuration on this.

 

com.adobe.cq.security.hc.dispatcher.impl.DispatcherAccessHealthCheck
com.adobe.cq.security.hc.webserver.impl.ClickjackingHealthCheck

View solution in original post