Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM 6.5.0 - Bundles Installed but not Active, WKND Project doesn't run

Avatar

Level 2

Hello, 

i have installed AEM 6.5.0 in my pc. I have downloaded the main file from here

https://github.com/adobe/aem-guides-wknd 

My versions:

Maven version: 3.8.6

Java version: 11.0.15.1

 

I inserted mvn command 

"mvn clean install -PautoInstallSinglePackage -Pclassic"

i have changed in the pom master file the version of core component. The version before war 2.19.2, i inserted the latest 2.20.6. The version 2.19.2 was in similar error. Here the line in my POM file master:

 

core.wcm.components.version>2.20.6</core.wcm.components.version
 
The build was fine, but i don't see the component and pages! I see white pages, i don't see the contents, i'm blind in AEM! Help me please!
 
Here the list of warning in my bundles
Immagine1.jpg
 
Help me please!
1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hi @FrancoBarresi ,

The github project which you have shared is for AEM 6.5.13+ - you can check in pom.xml post cloning.

<uber.jar.version>6.5.13</uber.jar.version>

You will have 2 options

  1. Install latest AEM Service Pack 6.5.13+ OR
  2. Create WKND project using batch mode for AEM 6.5.0

Although worth to check AEM Core component compatibility here  - https://experienceleague.adobe.com/docs/experience-manager-core-components/using/versions.html?lang=...

You can verify What AEM version is compatible to what AEM Core version.

 

If you look at you AEM Core Component bundle state it is in Installed state - that's because incompatibility of your AEM and core version.

Screen Shot 2022-07-10 at 4.30.01 PM.png

After Installing AEM 6.5.13 SP, AEM Core Component bundle is in Active state and pages are accessible as below

Screen Shot 2022-07-10 at 4.39.41 PM.png

Screen Shot 2022-07-10 at 4.41.36 PM.png

Hope that helps!

Regards,

Santosh

View solution in original post

4 Replies

Avatar

Correct answer by
Community Advisor

Hi @FrancoBarresi ,

The github project which you have shared is for AEM 6.5.13+ - you can check in pom.xml post cloning.

<uber.jar.version>6.5.13</uber.jar.version>

You will have 2 options

  1. Install latest AEM Service Pack 6.5.13+ OR
  2. Create WKND project using batch mode for AEM 6.5.0

Although worth to check AEM Core component compatibility here  - https://experienceleague.adobe.com/docs/experience-manager-core-components/using/versions.html?lang=...

You can verify What AEM version is compatible to what AEM Core version.

 

If you look at you AEM Core Component bundle state it is in Installed state - that's because incompatibility of your AEM and core version.

Screen Shot 2022-07-10 at 4.30.01 PM.png

After Installing AEM 6.5.13 SP, AEM Core Component bundle is in Active state and pages are accessible as below

Screen Shot 2022-07-10 at 4.39.41 PM.png

Screen Shot 2022-07-10 at 4.41.36 PM.png

Hope that helps!

Regards,

Santosh

Avatar

Community Advisor

@FrancoBarresi Via package manager

  1. Visit http://localhost:4502/crx/packmgr/index.jspScreen Shot 2022-07-10 at 5.38.45 PM.png
  2. Click to Upload and select package.
  3. Once it is uploaded -> Click to Install & wait for 10-15 min to resume AEM.

Avatar

Level 2

Thanks a lot @SantoshSai! You saved me! Immagine.jpgI have restarted many times to retunr all 612 bundles in active. After the installation of service pack many bundles were in status "resolved" and "installed", but now these are alls in ACTIVE. And now i can see the project! Thank you!