Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.
SOLVED

AEM 6.2 -- CRXDE doesn't work

Avatar

Level 2

Hi,

I installed plain vanilla AEM 6.2 onto our AWS server and the installation is success. When I login to CRXDE as admin user, it doesn't show up anything in the left panel. It is just empty. I checked the bundles and all the bundles are active. I opened up /siteadmin and it opens up fine. I checked /crx/packmgr and it also opens up fine. And when I checked the log I found an error stating 1.json not found. Below is the error snippet.

15.09.2016 13:31:38.221 *INFO* [127.0.0.1 [1473946298216] GET /crx/server/crx.default/jcr%3aroot/.1.json HTTP/1.1] org.apache.sling.engine.impl.SlingRequestProcessorImpl service: Resource /crx/server/crx.default/jcr:root/.1.json not found

This is author instance running on 4502 port. So I thought something went wrong with the installation and I did deleted the entire crx-quickstart folder and reinstalled again. Still I see the same problem. What could be the possible reason ? 

Any help would be appreciated.

Thanks,

Narendra N

1 Accepted Solution

Avatar

Correct answer by
Level 2

Hi Kautuk,

Yes, it is working. Sorry, forgot to update the thread. I am able to view crxde after having the org.apache.sling.jcr.davex.impl.servlets.SlingDavExServlet and crx explorer shows me entire repository with nosamplecontent runmode.

Thanks,

Narendra N

View solution in original post

11 Replies

Avatar

Level 10

I have asked support to look at this question - something is wrong as you should be seeing content in CRXDE lite when you sign in., 

Avatar

Level 2

Thanks Scott,

I did installed Publish and I see same on Publish as well. I tried installing on my local machine and it works fine. Am I missing something, error log doesn't provide me much information apart from the error log I pasted above. Is this something to do with AWS ? We have our current DEV, QA and PROD on AWS with 6.1(SP1) and they all are working fine. I am seeing this issue only with AEM 6.2.

Thanks,

Narendra N

Avatar

Level 2

Hi Varun,

When I checked the components I couldn't find the config for "org.apache.sling.jcr.davex.impl.servlets.SlingDavExServlet". I could find only "org.apache.sling.jcr.webdav.impl.servlets.SimpleWebDavServlet". So I used the curl command to create the new config and now I see it and I am able to see the crxde properly. So I have one question here. I started the server as production ready mode using runmode as nosamplecontent. Does this completely removed the SlingDavExServlet config ? 

Thanks,

Narendra N

Avatar

Employee

Yes, using runmode as nosamplecontent will cause this.

Avatar

Level 10

It seems that for the CRXDE Lite console to load for the anonymous user we have to grant read permission for the anonymous user to its own profile. For example if the user profile for the anonymous user is located at /home/users/p/pecWFPrxeWv-KeWCP1uv, then the user has to have read access to this path for the console to load
properly.

Avatar

Level 7

Hi Naren,

If you are using nosamplecontent secondary run mode. Then it will disable Adobe crxde support bundle from Felix console. If you want to view crxde properties, then you can use CRX Explorer console. It will be available with nosamplecontent runmode.

regards,

Ankur

Avatar

Level 2

Hi Sham,

It is not with the user. Even admin can't see the crxde lite repository. But thanks for this point. I will keep this in mind for anonymous user.

Thanks,

Narendra N

Avatar

Level 2

Hi Ankur,

This is interesting. I will check this out. 

Thanks,

Narendra N

Avatar

Administrator

Is it working now ?

Can you please share, how did it worked ?

~kautuk



Kautuk Sahni

Avatar

Correct answer by
Level 2

Hi Kautuk,

Yes, it is working. Sorry, forgot to update the thread. I am able to view crxde after having the org.apache.sling.jcr.davex.impl.servlets.SlingDavExServlet and crx explorer shows me entire repository with nosamplecontent runmode.

Thanks,

Narendra N