Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events

Adobe Granite HTML Library Manager

Avatar

Level 3

Hello Community - HTML Library Manager (for clientlibs) is using the system user "clientlibs-service" and having read permissions for /apps, libs, var paths, For some reason, the permissions are getting overwritten in our environments. I have already verified that it's not something we're overwritten, Can someone tell me if you have encountered similar kind of issues and because of this issue inline clientlib impln is not working. is this something we can assign/retain the permissions via repoinit configs so that we can preserve the permissions. Please let me know your thoughts on this.

7 Replies

Avatar

Community Advisor

Hi @test1234567 ,

To fix this follow below steps:

  1. Go to http://host:port/crx/de/index.jsp web app and log in as admin.

  2. Browse to the folders below and validate that clientlibs-service user has these permissions:

    • /apps Allow jcr:read
    • /libs Allow jcr:read
    • /etc Allow jcr:read
    • /var/clientlibs Allow jcr:read, rep:write
     

    To view permissions, browse to the node you want to view or modify permissions for. Then, on the lower-right panel of CRXDE click the Access Control tab.
    If the clientlibs-service user itself is missing, then go to a working AEM instance and create a package of the path /home/users/system/clientlibs-service. Then install that to your broken instance.

    Hope it helps!

    Thanks
    Tarun

Avatar

Level 3

Thanks for your reply. I have already added the required permissions to the system user. My questions is how we can prevent it and also interested to see what service/conifg is manipulating the permissions. Have you encountered these kind of issues in your instance?

Avatar

Community Advisor

@test1234567 Can you check if this is something coming from your custom code and also check what specific permissions are getting overwritten for  clientlibs-service.
Try to create a new instance locally and compare it with that, this should not be something happening from AEM OOTB.


Thanks
Tarun

Avatar

Community Advisor

What is the AEM version ? Was there any version upgrade recently ? If so , was it working fine before ?

Avatar

Community Advisor

Hi, 

I have never encountered such an issue. The repo init won't work for your situation because it only runs once when the repository starts for the first time. If you are using AEM on-premise, I would suggest creating a new instance locally and checking if the same behavior exists without your codebase. Then, validate if the issue appears after deploying your custom code. If the issue does not occur, then something might have been corrupted in your instance. If the issue appears, then it's likely something within your code.



Esteban Bustamante

Avatar

Community Advisor

@test1234567 

 

You have mentioned that you have already provided permissions.

 

But to analyze what causes it, you might want to monitor when they get removed? And from there one can backtrack and find cause.

 

We have not noticed the issue, so it might be something specific to your environment/ code.

 

Also, Is it an AEM 6.5 or a Cloud instance?


Aanchal Sikka

Avatar

Administrator

@test1234567 Did you find the suggestions from users helpful? Please let us know if you require more information. Otherwise, please mark the answer as correct for posterity. If you've discovered a solution yourself, we would appreciate it if you could share it with the community. Thank you!



Kautuk Sahni