Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Adobe campaign AEM pages linking

Avatar

Level 4

Hi,

 

I am new to adobe campaign and what I have been trying to achieve is create a page in AEM and trigger a workflow , complete workflow, and publish page on author instance.

 

when I try to link aem page in Adobe campaign , I am getting below error.

Can anyone shed some light on below error.

 

Interesting thing is existing emails that are linked working fine, relinking is working fine for already linked emails.

 

This is happening for any new email linking/

 

Response is not a valid JSON:<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>500 Internal Server Error</title>
</head><body>
<h1>Internal Server Error</h1>
<p>The server encountered an internal error or
misconfiguration and was unable to complete
your request.</p>
<p>Please contact the server administrator at 
 root@localhost to inform them of the time this error occurred,
 and the actions you performed just before this error.</p>
<p>More information about this error may be available
in the server error log.</p>
</body></html>

Error while executing the method 'LinkAEMContent' of service 'nms:delivery'.

 

Thanks.

Sri

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hi @sreedobe 

It seems to be having a configuration issue. It could be an issue with the author instance port. Please see the thread below:

https://experienceleaguecommunities.adobe.com/t5/adobe-campaign-standard/aem-lt-gt-adobe-campaign-st...

 

Also you do not have to publish any campaign page on author. "Publish to Adobe Campaign Workflow" should be enough and the content will be replicated on Adobe campaign instance if all configurations are correct. 

 

Thanks!

View solution in original post

1 Reply

Avatar

Correct answer by
Community Advisor

Hi @sreedobe 

It seems to be having a configuration issue. It could be an issue with the author instance port. Please see the thread below:

https://experienceleaguecommunities.adobe.com/t5/adobe-campaign-standard/aem-lt-gt-adobe-campaign-st...

 

Also you do not have to publish any campaign page on author. "Publish to Adobe Campaign Workflow" should be enough and the content will be replicated on Adobe campaign instance if all configurations are correct. 

 

Thanks!