Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

No content in Android App

Haeme_Ulrich
Level 4
Level 4

I made an Android App and installed it on a HTC phone. Unfortunately I don't get any content even though I published a collection with added articles.

What to do?

Thanks

Haeme Ulrich

1 Accepted Solution
Neil_Enns_-_Ado
Correct answer by
Employee
Employee

I suspect you're hitting a bug we had where in some cases the updates are detected but not shown in the app. We've already got this fixed and it'll be out in the next beta update.

Neil

View solution in original post

7 Replies
Neil_Enns_-_Ado
Employee
Employee

Hi Haeme,

What's your top-level collection structure look like?

Neil

Haeme_Ulrich
Level 4
Level 4

I deleted the App from the device and installed it again. It is running now. I assume that there were some problems with the distribution server?

Thanks

Haeme

Neil_Enns_-_Ado
Employee
Employee

Did you publish the empty top-level collection before adding the article and publishing again? Or did you only publish once?

Neil

Haeme_Ulrich
Level 4
Level 4

I can't remember for sure. I would say that I published the article before the collection.

Thanks

Haeme

Haeme_Ulrich
Level 4
Level 4

Neil, I found that I can force a content update in the Android App when I clear the Cache ("clear data") in the App Info. Could be that this trick is helpful for others as well.

Best

Haeme

Neil_Enns_-_Ado
Correct answer by
Employee
Employee

I suspect you're hitting a bug we had where in some cases the updates are detected but not shown in the app. We've already got this fixed and it'll be out in the next beta update.

Neil

View solution in original post