Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Invalid bundle error

Avatar

Level 2

My app goes through the Application Loader and says that it is a success but then I get an email from Apple saying...

Invalid Bundle - This app includes files that were built with bitcode enabled but without doing an Archive or Install build, possibly from a library or framework that was imported but not built as part of the project. Full bitcode content is only generated in an Archive or Install build.


I see no options for this anywhere, for building certs or in DPS. Has anyone run into this issue or have any ideas?

1 Accepted Solution

Avatar

Correct answer by
Employee

This is now resolved. You'll need to edit the app in App Builder and click the submit button to force a rebuild. The rebuilt app should upload successfully to iTunes. Thanks for reporting this and for your patience while we addressed it!

Neil

View solution in original post

12 Replies

Avatar

Employee

Try rebuilding your app. We had a deployment of the iOS viewer that was up briefly that had an error, and it was resolved at 1:18pm today. Chances are you were one of the lucky few who built in the tiny window where we had an incorrect binary posted

If rebuilding doesn't fix it please let me know.

Neil

Avatar

Level 2

by rebuilding do you mean create a new app? Or redownload the current unsigned one and resign it?

Avatar

Employee

Edit your existing app in the dashboard and wait for the Submit button to light up. Click submit, which will force a rebuild of the app. Then download and sign.

Neil

Avatar

Level 2

thanks for the reply I rebuilt it and resubmitted but I'm getting the same error.

Avatar

Employee

Have you tried installing the app on your device before submitting? Does it install?

Neil

Avatar

Employee

Also are you sure you have the most up-to-date version of Application Loader? What version is installed?

Neil

Avatar

Level 2

I have application loader 3.0, I haven't tried a direct install just yet but will try to tomorrow.

Avatar

Employee

Ok, thanks. We're trying something on our end too to see if we can replicate the issue.

Neil

Avatar

Employee

Hi Matt,

We were able to reproduce the problem internally. The status page at http://status.adobedps.com/ should be updated shortly. We're working on a fix.

Neil

Avatar

Level 2

Neil I'd order you a pizza if I could. Thank you.

Avatar

Employee

Aw, thanks. Save it for after we make the fix


Neil

Avatar

Correct answer by
Employee

This is now resolved. You'll need to edit the app in App Builder and click the submit button to force a rebuild. The rebuilt app should upload successfully to iTunes. Thanks for reporting this and for your patience while we addressed it!

Neil