Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

2018.1.001 app icons show Preflight icons

Scott_Landis
Level 2
Level 2

Hi All,

Just built for the first time for iOS with 2018.1.001. The icons and splash screens for the app are now showing the preflight icon instead of my app icon.

The app is signed for enterprise distribution.

Please advise on a fix.

-Scott

1 Accepted Solution
Anthony_R
Correct answer by
Level 3
Level 3

The missing splash screen image for iPhoneX is a known issue and a fix is currently being implemented for an upcoming release of AEM Mobile.

In the meantime there is a workaround you could do.

  • Unzip the downloaded IPA
  • Show package contents of Jupiter
  • Replace 'LaunchImage-1100-Landscape-2436h@3x.png' and 'LaunchImage-1100-Portrait-2436h@3x.png' with your own splash screen images
  • Re-zip the IPA
  • Run the IPA through the signing tool as usual

Anthony

1412889_pastedImage_1.png

1412890_pastedImage_2.png

View solution in original post

16 Replies
Anthony_R
Level 3
Level 3

Hi Scott,

Are you enterprise signing your app with the 2018.1 version of the app signing tool?

The 2018.1 version of the iOS viewer upgraded to using XCode9 in order to better support iOS 11 which also required an update to the signing tool as well.

Anthony

Scott_Landis
Level 2
Level 2

Yes, I am using the updated version of the app signing tool.

Anthony_R
Level 3
Level 3

The signing tool should be handling the icon replacement now so it does sound like you may have discovered an issue.

Anthony_R
Level 3
Level 3

Have you also upgraded all your tools to XCode 9?

Anthony_R
Level 3
Level 3

Something like this: Unauthorized - Apple Developer

Unless you have the full XCode IDE installed.

Anthony_R
Level 3
Level 3

If you are still having issues please attach your ~/aemm-sign-tool.log.

Scott_Landis
Level 2
Level 2

Opened Xcode to confirm version and I got a new set of patches, which seems to have fixed the issue.

Thanks for the help.

Scott_Landis
Level 2
Level 2

Sorry Anthony, spoke too soon.

By getting the new patches I got the fix needed on iPad but iPhone X still displays the Preflight splash screen (icon is fine).

Scott_Landis
Level 2
Level 2

After re-reading the release notes for 2018.1.001, it seems that it is intended that the iPhone X displays the "default" images for the iPhone X, since there is no option to add iPhone X sized splash screens in the App Build menu. And the default images are Adobe branded Preflight assets?

Is this true?

I can't see how I can convince a client that this is ok, and I do not expect that Apple will accept an app that has a mismatched splash screen on their flagship phone.

TommyDAQ-Bates
Level 6
Level 6

Jumping on this band wagon. We are building a custom Preflight app, actually updating one that we've been using for the past year.

Signing Tool: release.2018.1

Xcode: 9.1

Splash Screens are appearing. However...

App Icon is showing default AEM Preflight icon.

The Custom app icon is visible DURING the installation process, but as soon as installation is finished, it reverts to the AEM icon.

Is there a fix for this?

Vinod_Tanwar
Employee
Employee

Along with newer version of AEM Mobile App Signing tool. You also need to update to Xcode 9.2 or later. To download Xcode for free from the Apple app store, go to https://itunes.apple.com/us/app/xcode/id497799835.

--

Vinod Tanwar

Scott_Landis
Level 2
Level 2

Vinod, Going to Xcode 9.2 fixes the app icon issue but does not fix the splash screen on the iPhone X. Is there any timeline for that fix? I'm quickly approaching a deployment deadline and cannot deploy with the iPhone X displaying a mismatched splash screen.

Anthony_R
Correct answer by
Level 3
Level 3

The missing splash screen image for iPhoneX is a known issue and a fix is currently being implemented for an upcoming release of AEM Mobile.

In the meantime there is a workaround you could do.

  • Unzip the downloaded IPA
  • Show package contents of Jupiter
  • Replace 'LaunchImage-1100-Landscape-2436h@3x.png' and 'LaunchImage-1100-Portrait-2436h@3x.png' with your own splash screen images
  • Re-zip the IPA
  • Run the IPA through the signing tool as usual

Anthony

1412889_pastedImage_1.png

1412890_pastedImage_2.png

View solution in original post

AndrewTop
Level 2
Level 2

You should now be able to upload iPhone X splash screens when editing the Apps in the portal.  Those will be used in the IPA as the 1100 images.

Please let us know if you run into any problems.