Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.

Asset Sourcing in AEM from Brand Portal - Email Updates for "Status updated for contribution folder publish to AEM" is always sent with "successfully published to AEM" message

Avatar

Community Advisor

11/23/23

Request for Feature Enhancement (RFE) Summary: OTB Workflow triggering Email service as assets are pushed from Brand Portal to AEM are incorrect.
Use-case: The default workflow when pushing assets from Brand Portal to AEM has the following status - 
1.  The contribution folder asset-sourcing-test is queued for publish to AEM.
2.  The contribution folder asset-sourcing-test is successfully published to AEM.

The 2nd mail comes even if the Asset Contribution Status in Brand Portal is marked as "Failed" in Status. 
This is incorrect as it gives user the perception that the push from Brand Portal to AEM is successful.
Current/Experienced Behavior: Current mail states " The contribution folder asset-sourcing-test is successfully published to AEM."
Improved/Expected Behavior: The mail should state that " The contribution folder asset-sourcing-test failed in publishing to AEM.
Environment Details (AEM version/service pack, any other specifics if applicable): AEMaaCS - 2023.11.14227.20231108T162349Z
Customer-name/Organization name: TA Digital
Screenshot (if applicable): Rohan_Garg_0-1700745109281.pngRohan_Garg_1-1700745158455.png

 

Code package (if applicable):  
1 Comment

Avatar

Administrator

12/5/23

@Rohan_Garg 

Thanks for proposing this idea
 
This has been reported to the engineering under the internal reference ASSETS-32214. The product team will triage this request to verify feasibility based on the prioritization model. This post will be updated according to the Jira request status.
Status changed to: Investigating