Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

publishing error: Failed to retrieve references for selected pages.

sybrandl3158301
Level 1
Level 1

Hi there,

Hope someone can help out.. 🙂

On our authoring server, once click on the Publish Icon in the touch UI, we get the following error: Failed to retrieve references for selected pages.
Does anyone have some idea what might be the issue?

We can unpublish, not issue there, but just on the publishing side, its not working..

Any thoughts would be greatly appreciated..

Thanks

Sybrand Lubbe

1 Accepted Solution
AnkurAhlawat
Correct answer by
Level 7
Level 7

Hi Sybrand,

Sorry for late reply, might be you have already fixed this issue, but it will help others.

On this specific page you have used an OOB reference component, which is not able to retrieve its references. You can either create a package of this page from other publish node or can redeploy the code on this publish server.

View solution in original post

5 Replies
deepak_k_
Employee
Employee

Is it specific to Forms or are you trying SITES page?

sybrandl3158301
Level 1
Level 1

Hi there,

No, not to forms, if I am in the site section in the Touch UI interface and select a page to publish, its giving me this error message and doesn't publish the page..

any thoughts?

jayak13010535
Level 3
Level 3

One Quick Question, Have you applied Target on this page. Because same happens with me too if I perform targeting and try to publish the page. 😞

Any fix for this issue ?

jayak13010535
Level 3
Level 3

Hi Sybrand,

I have also faced the same issue. I have noticed whenever there are any references to a page (eg. Campaigns, Activities), then Failed to retrieve references for selected page error comes on publishing a page. 

Any solutions you have got to resolve this?

Thank you in advance.

~Jay

AnkurAhlawat
Correct answer by
Level 7
Level 7

Hi Sybrand,

Sorry for late reply, might be you have already fixed this issue, but it will help others.

On this specific page you have used an OOB reference component, which is not able to retrieve its references. You can either create a package of this page from other publish node or can redeploy the code on this publish server.

View solution in original post