Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

How to bring responses in 'Responses' tab of a survey

ckumari12
Level 4
Level 4

Hello,

I am not using recipient schema. I have a custom table with customer data and my target mapping is created on that table and the  survey table created using target maping is 'yyy:webAppLogxxx'. I have added custom fields in this schema.

I have created a survey with document as 'custom table' and library as 'yyy:webAppLogxxx'.

I am able to take response from customer and it is getting stored in 'yyy:webAppLogxxx' table but I am not able to see it in response tab of the survey.

I am trying to configure the custom fields in that tab using Archived fields (temp:webAppLogxxx) but no values are loaded.

Can you please help me how can I bring my responses in response tab of 'Survey' webapp.

2 Replies
Jean-Serge_Biro
Community Advisor
Community Advisor

Hi Ckumari,

Please take care, most of surveys use the schema nms:webAppLogRcpData (so the same for you with Data extension for your custom target mapping).

The webAppLogRcpData contains values responses as archived fields in XML format (memo fields, cblob/TEXT sql column).

In order to have Response tab filled, please check in your webApp, in Properties page, select Advanced parameters and look for the checkbox Save the response trace (I don't remember exactly the label corresponding to the French label below):

1844532_pastedImage_0.png

Some of the Response list are filled with webAppLogRcp schema content, other with webAppLogRcpData content.

Regards
J-Serge

Jyoti_Yadav
Community Advisor
Community Advisor

Hi,

When you are creating survey form and mapping it to custom table, you need to save same in your 'Webform Properties'.

1844726_pastedImage_1.png

Have you changed Storage library to one where you are storing your response.

You also need to configure Advanced Parameter and select 'Log Response'.

Also, you need to define link to custom schema in 'nms:webApp' form. As in that Responses tab is linked to 'webAppLogRcp' and that might be the reason why you are not able to view in survey responses tab.

1844727_pastedImage_3.png

Thanks,

Jyoti