Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

How to bring responses in 'Responses' tab of a survey

Avatar

Avatar
Validate 1
Level 3
ckumari12
Level 3

Likes

17 likes

Total Posts

38 posts

Correct Reply

4 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 3
ckumari12
Level 3

Likes

17 likes

Total Posts

38 posts

Correct Reply

4 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
ckumari12
Level 3

10-01-2019

Hello,

I am not using recipient schema. I have a custom table with customer data and my target mapping is created on that table and the  survey table created using target maping is 'yyy:webAppLogxxx'. I have added custom fields in this schema.

I have created a survey with document as 'custom table' and library as 'yyy:webAppLogxxx'.

I am able to take response from customer and it is getting stored in 'yyy:webAppLogxxx' table but I am not able to see it in response tab of the survey.

I am trying to configure the custom fields in that tab using Archived fields (temp:webAppLogxxx) but no values are loaded.

Can you please help me how can I bring my responses in response tab of 'Survey' webapp.

Replies

Avatar

Avatar
Validate 1
MVP
Jean-Serge_Biro
MVP

Likes

353 likes

Total Posts

464 posts

Correct Reply

153 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile

Avatar
Validate 1
MVP
Jean-Serge_Biro
MVP

Likes

353 likes

Total Posts

464 posts

Correct Reply

153 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile
Jean-Serge_Biro
MVP

14-10-2019

Hi Ckumari,

Please take care, most of surveys use the schema nms:webAppLogRcpData (so the same for you with Data extension for your custom target mapping).

The webAppLogRcpData contains values responses as archived fields in XML format (memo fields, cblob/TEXT sql column).

In order to have Response tab filled, please check in your webApp, in Properties page, select Advanced parameters and look for the checkbox Save the response trace (I don't remember exactly the label corresponding to the French label below):

1844532_pastedImage_0.png

Some of the Response list are filled with webAppLogRcp schema content, other with webAppLogRcpData content.

Regards
J-Serge

Avatar

Avatar
Boost 50
MVP
Jyoti_Y
MVP

Likes

87 likes

Total Posts

123 posts

Correct Reply

55 solutions
Top badges earned
Boost 50
Shape 1
Boost 5
Give Back 5
Give Back 3
View profile

Avatar
Boost 50
MVP
Jyoti_Y
MVP

Likes

87 likes

Total Posts

123 posts

Correct Reply

55 solutions
Top badges earned
Boost 50
Shape 1
Boost 5
Give Back 5
Give Back 3
View profile
Jyoti_Y
MVP

14-10-2019

Hi,

When you are creating survey form and mapping it to custom table, you need to save same in your 'Webform Properties'.

1844726_pastedImage_1.png

Have you changed Storage library to one where you are storing your response.

You also need to configure Advanced Parameter and select 'Log Response'.

Also, you need to define link to custom schema in 'nms:webApp' form. As in that Responses tab is linked to 'webAppLogRcp' and that might be the reason why you are not able to view in survey responses tab.

1844727_pastedImage_3.png

Thanks,

Jyoti