Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Getting error when "Registration on the tracking server"

Avatar

Level 2

Hi,

Can someone help me?

I have an error "NMS-470004 There is no database identifier defined" when configuring the tracking server. I guess I need to write the Databaseid in config-<instance>.xml before configuring, right? But I don't know how to find the "Databaseid". My database server is Postgresql.

Thank you in advance.

 

 

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hi,

 

Tracking client's database identifier is in xtk:option 'XtkDatabaseId'.

It's an arbitrary string used by tracking server to pair itself with an instance db.

 

Thanks,

-Jon

View solution in original post

3 Replies

Avatar

Correct answer by
Community Advisor

Hi,

 

Tracking client's database identifier is in xtk:option 'XtkDatabaseId'.

It's an arbitrary string used by tracking server to pair itself with an instance db.

 

Thanks,

-Jon

Avatar

Level 2
Thank you for your reply. I think I have found the root cause, the webmdl@default didn't start automatically. I don't know how to start it, I tried to run "nlserver start webmdl@default" to start, but failed, it shows "No task corresponds to mask "webmdl@default". Nothing has been started.""

Avatar

Community Advisor

Hi Alan,

you should try to start it with the instance name: nlserver start webmdl@your_instance_name and set flag autostart to True in server configuration for this process.

Regards,
Milan